27

I have four keyboards and I have defined Ctrl+1, Ctrl+2 and Ctrl+3 ... hot-keys for them. The problem is that either all of the hot-keys or the first one is removed regularly. For example every time the computer goes to sleep (or even locked) all of them are removed.

I even tried other hot-keys (Ctrl+Shift+1, ... Ctrl+Shift+4) or (Alt+Shift+1, ... Alt+Shift+4) and the problem still exist.

If I assign a transition key (Left Shift+Alt) it will work but that's not that useful when you have more than 2 keyboards and you want to regularly change the keyboard.

It appears that the problem has existed in Windows 8 too (and has something to do with welcome screen) but the solution I found does not work on Windows 10 (http://answers.microsoft.com/en-us/windows/forum/windows_8-desktop/custom-hotkeys-to-change-input-language-disappear/66d1d89d-e5dc-41e1-a8b3-48d596ab8e11).

Has anyone been able to solve this problem?

3
  • I myself have that problem. But no idea how to solve it. Various 'fixes' found on the internet did not help for me... – Zaheylu Jan 27 '16 at 15:05
  • I found several similar items on windows "Feedback Hub": 1, 2, 3, 4, 5 - consider up-voting them - there's a tiny chance that this might help. – i3v Nov 21 '17 at 19:11
  • Ran into same problem. Windows 10 20h2. I even cannot change hotkeys - when press Apply - they are reseted to ctrl+1 and ctrl+2 immediately. I restarted PC in safe mode: windows+R - msconfig - Boot - tick Safe boot, restart. In this mode mode both hotkeys are None. It seems they are set by some driver in normal mode indeed. I changed them to some useless combination for me like ctrl+shift+8 and ctrl+shift+9, restarted again in safe mode. Binds are saved. Then changed them to None. Restarted back to usual mode. And binds stopped reseting by themselves. – Doctor Coder Feb 27 at 4:44
37

I finally found the solution and I am posting, in case someone else has the problem.

1- Define your hot-keys.

2- Search and find the "region" settings palette and go to administrative tab.

region-administrative tab

Now go to "Copy Settings" section.

copy settings

Select both tick boxes below the window and press ok.

In my case this applied the settings in a way that they are no more removed.

Edit: In case you cannot find the language Hot-key definition in windows 10, in the latest editions, it is here:

enter image description here

10
  • 1
    That's the solution found in the link you have posted in your question isn't it? – Zaheylu Jan 27 '16 at 15:55
  • 3
    The solution was for windows 8. It is the same but with a bit difference for windows 10. In windows 10, the settings are in a different place than the one mentioned in that link (for windows 8). – wmac Jan 28 '16 at 4:13
  • 2
    It looks like the issue is still there. Sometimes it works, sometimes not. It specially after additional updates - you have to re-set all the hotkeys again, but no warranty that they will work. – Tigran Jun 16 '17 at 7:01
  • 1
    What to do if there are two users and both of them have different hotkeys? – St.Shadow Nov 5 '17 at 7:52
  • 1
    Yes, copying settings from current user to default user works. But I could do this via RegEdit only. I copied two entries (for two custom keys) from [HKEY_USERS\S-1-(MYUSER-ID)-1001\Control Panel\Input Method\Hot Keys\00000100] and 00000101 to [HKEY_USERS\.DEFAULT\Control Panel\Input Method\Hot Keys] ... – yvolk Nov 28 '19 at 9:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.