17

Utilities like vimperator allow editing content of HTML form fields in an external editor.

With vimperator there is shortcut Ctrl+I which, when in an edit box, opens the text in an external editor.

In the past, it was possible to use this in Stack Overflow. Since the introduction of more editing features, however, Ctrl+I is not opening the external editor, but inserts *emphasized text*.

Is there any way configure vimperator to start an external editor for editing Stack Overflow text?

migrated from vi.stackexchange.com Jan 26 '16 at 23:07

This question came from our site for people using the vi and Vim families of text editors.

14

Stack Overflow and other Stack Exchange sites, like many other websites with embedded editors, bind various keyboard chords to editing commands. These are sometimes called access keys (if you want to do a web search) and are bound when the page is loaded. In your case, Vimperator's default keymap for editing a HTML text area in an external editor, Ctrl-i, is overridden. Instead of its default operation it inserts *emphasized text*. To get around this you can add a new mapping to your .vimperatorrc. I have used

inoremap <Leader>i <C-i>

My <Leader> key is -, so with the focus on a HTML text area I use -i begin editing in an external editor.


It is clear from the question that you have used this feature before, but for those who haven't, the option that controls which external editor to use is 'editor'. For gVim/MacVim, use the -f flag for "foreground", preventing that Vim forks its own process (and loses its association with the edited text area). See :help 'editor'. I use MacVim and the two relevant lines of my .vimperatorrc therefore read:

set editor="/usr/local/bin/mvim -f"
inoremap <Leader>i <C-i>
  • Regarding second part of your answer. It seems that the browser is not usable when editor is open with -f flag. Is it possible to use the browser somehow while having editor open for some text field? – Granitosaurus Jul 11 '16 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.