0

I'm trying to remote SSH into my Beagle Bone Black and Raspberry Pi while at my house (eventually want to from outside but I think I need to re-flash my router with custom firmware for it to support free dynamic DNS service). I think I correctly set up port forwarding on Linksys E2500 Wi‑Fi Router (picture provided below). From what I understand I need to set the local IP of the BBB and Pi wlan interface static which i'm in the process of doing. However I know their local IP's right now and have set the port forwarding according to that and i'm still having trouble connecting. I was told I first need to SSH into my router at 192.168.1.1 but I'm not sure how to go about doing that and I'm having trouble finding resources online that explain it. Both boards are running Debian the pi is running RASPBIAN JESSIE and the BBB is running Debian 7.8

Port forwarding setting on my router for my BBB at its currently assigned IP

1
  • 1
    what does port forwarding have to do with this? from which kind of system are you trying to connect? have you ever heard of PuTTY?
    – jiggunjer
    Jan 27, 2016 at 1:19

1 Answer 1

1

You do not have to SSH into the router to access the Raspberry Pi and BBB from SSH. If you are on the same local network as the two devices you can SSH into them using their Local IPs on port 22. They don't even have to be static IPs (even though its extremely convenient).

BTW if you ever do plan to SSH into your devices from another outside network, No-IP lets you run the dynamic IP updater service on any Linux computer within your network (say the PI, or BBB). Read their installation guide here (Note: You will still need to port forward on your router, but at least you won't need to reflash it)

2
  • Awesome thank you, I thought I tried to directly SSH into my boards while they where on my network but I guess I didn't. It works fine
    – CompMan
    Jan 27, 2016 at 4:52
  • @MichaelTangy Great! If this worked for you could you mark this as the answer (click the checkmark to the left of the answer). Thanks!
    – c0deous
    Jan 27, 2016 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .