2

When sharing a file/folder in Windows 10, the connection is horribly slow.

What I am trying to do is to share a folder on one computer, and access that folder and the files within from another computer on the same WiFi network. More precisely, the shared folder contains video files (movies) that I would like to access and watch from other computers in my household.

The problem is that not only does it take forever to load the directory hierarchy on the client computers, but also playing the files on a client computer is horrible (low frame rates, incredible loading times when opening a file and / or seeking).

It does not appear to be a network issue, as I was able to get 10 to 35 Mbps over WiFi on speedtest.net. I could also average 4 to 5 Mbps on Torrent.

The problem seems to be strictly in file sharing in my network. Regardless of whatever machine hosted the file, the transfer is a slow 1.2 Mbps.


Here is a list of the hardware:

  • One 3 year old desktop PC
  • One 2~ year Asus laptop (host)
  • One 1 year Acer laptop
  • One Intel Compute Stick with Windows.
  • Asus RT-N12E 300 Mbps Wireless Router

What I've tried to diagnose the problem:

  • Ensure distance was not the problem (all were placed around 3 meters away).
  • Set all devices to 802.11N standard.
  • Set the router to channel 6 (channel with least interference).
  • Disconnected the network from the internet (only slight improvement).
  • Ran netsh interface tcp set global autotuning=disabled on the computers.
  • Did you solve this? – rolls Jul 19 '17 at 7:27
0

Under Network & Sharing select Change adapter settings -> right-click on your wireless adapter -> properties -> click configure -> click the advanced tab.

Disable both the settings Large Send Offload V2 (IPv4) & IPv6). Reboot.

Repeat on all the systems you want to transfer files to/from on your network.

Let us know if that doesn't work.

  • Already disabled and still extremely slow. – rolls Jul 19 '17 at 7:25

protected by Community Apr 7 '17 at 20:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.