1

I am facing a problem trying to finally upgrade one of my machines from Windows 7 to Windows 10. I am currently running Windows 7 Prof SP1 32bit on a Dell Optiplex 755 (non-UEFI BIOS). Just a few days ago I upgraded the Optiplex from Core2Duo E4400 to a Core2Duo E8500, as well as increasing from 2 to 6 GB of ram. As storage I have two 200GB Samsung SATA harddrives in a RAID0 setup.

First, I was dualbooting with archlinux and the old grub-legacy as my boot-loader, installed to the MBR of the raid0-fakeraid, that is /dev/mapper/isw_xxxxxx. So Windows and Linux were sharing the same partition layout (no software raid nowhere, all pure fakeraid). However, Windows 10 didn't like the setup (it seems with grub2 it's better), and would fail to even start the installation (giving some obscure error "Something went wrong"). So, I bootet from a Windows 7 SP1 installation disc into the recovery menu and put back the original Win7 bootloader to MBR. So now the system boots fine into Win7, without GrUB showing up.

However, the problem is still with the upgrade to Windows 10. I put the x86/64-combined installation media to a USB stick, and from within Windows 7 I start the setup.exe. So the installer confirms my system is upgradable and starts with the installation, copying all the files and eventually goes to reboot. Then at this point I see the Windows-10-splashscreen for a bit (as if everything is going normal) but then I am presented with what looks like a limited version of the "Advanced Start Options", with only options: -Troubleshoot -Shut down In the troubleshoot-menu I have quite some options, but all indicate something is not right: Fix MBR, Reset computer, Revert to previous Windows and the like.

So I went back and pressed shutdown. Turning on the computer again and Windows 7 boots again like normal, then showing the following message from the Win10-installer:

We couldn't install Windows 10

We've set your PC back to the way it was just before you started installing Windows 10.

0xC1900101 - 0x20017
The installation failed in the SAFE_OS phase with an error during BOOT operation

I tried for a second time, but same result. I searched a bit around but I cannot find somebody else that had the same problem. Only boot loops, or totally failed systems. But nothing like mine. So I am a bit lost as where to start digging.

One added note: Reinstalling Win7 at the moment is no option! For some reason, the legit(!) key for the Win7 installation was deleted from the registry (now shows as BBBBB-BBBBB-BBBBB-BBBBB-BBBBB), and I cannot find it written down anywhere anymore (and the Email-account that I got it mailed to I have no access to anymore). The system shows as activated though and passes the genuine check.

One more note: Could it have to do with the recent upgrade to 6 GB ram? I know 32-bit only supports 4, but because of my serial dilemma I want to upgrade to 10 first (so 32 bit) and then fresh install over with 64 bit.

EDIT: So, I am officially upset right now. I tried all different kinds of thing like unplugging every unnecessary device (including DVD), uninstall all kinds of drivers, delete all linux partitions, but to no avail. Then I made a tiny big mistake: I deleted the 100 MB system-reserved partition, and did a fixmbr again afterwards. This somehow killed the filesystem. Recovery with testdisk didn't work. So this installation is lost! Fortunately, I found an old drive from this PC which had also a running Win7 installation, but I apparently (from the product code) I used a different key. So I still have a valid option to update, I just lost one Win7 key :-/ But what bugs me almost the same is that I will not be able to find out if I would have been able to fix the problem in the end!!!

  • Your Windows 7 key is on the COA sticker on the machine – Ramhound Jan 27 '16 at 22:10
  • No. 7 was not available back then. It has a Windows XP COA sticker. But as a student I had free access to Windows 7 from the MSDNAA program. Hence the key is lost in my old student mail account. The license says I am still eligible to use it after graduation! – TJJ Jan 27 '16 at 22:52
  • This is very interesting, have you tried the fix MBR option, as it may be booting a semi functional recovery partition instead of an OS? – Sam3000 Jan 27 '16 at 22:57
  • Yes, I did. Didn't change the problem. – TJJ Jan 27 '16 at 22:59
0

So, in the end I found out, it has to do with the RAID0 being the system drive!

I reinstalled Win 7 SP1 on the RAID0 with another key that I would usually use for playing with VMs. Fresh install, all updates afterwards. The Windows 10 update would turn up with the same strange behaviour. Then I deleted the RAID0, AGAIN installed Win 7 SP1 normally on one of the SATA drives (without RAID-mode), all updates, and afterwards the Windows 10 update worked just as it should! A bit of further research revealed that I wasn't the only one having this problem and that it is Windows 10 that has some strange problem with the Intel Rapid Storage drivers. It seems to be always the problem if the system is running from the RAID-drive. No problem, if the RAID is just extra storage.

I wanted to get rid of the RAID0 anyways, as todays drives are fast enough for my needs. So I can perfectly leave it like this and live with it happily ever after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.