34

So I am trying to compile gyp and it wants to call VCBuild.exe apparently...

MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe".
 To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visua
l Studio 2005 or 3) add the location of the component to the system path if it
is installed elsewhere.  [C:\...\node_module
s\browser-sync\node_modules\socket.io\node_modules\engine.io\node_modules\ws\no
de_modules\utf-8-validate\build\binding.sln]

So I install the .Net framework using this but when I go to the cmd line I get...

'VCBuild.exe' is not recognized as an internal or external command,
operable program or batch file.

so what am I missing what do I need to get VCBuild without Visual Studio?

9
  • I just entered VCBuild.exe
    – Jackie
    Jan 28, 2016 at 19:25
  • I realize what it means but I don't even think that framework will install on Win 10. I tried that already
    – Jackie
    Jan 28, 2016 at 19:26
  • Where would that be?
    – Jackie
    Jan 28, 2016 at 20:48
  • Also this was Windows 10 so I am not sure how well Vs 2005 will run and I don't have a copy so those are no-go options.
    – Jackie
    Jan 28, 2016 at 20:49
  • 1
    So I have to install an entire IDE to get this tool?
    – Jackie
    Jan 28, 2016 at 21:31

5 Answers 5

66

npm install -g windows-build-tools

ran in an administration window:

Starting installation...
Launched installers, now waiting for them to finish.
This will likely take some time - please be patient!
Waiting for installers... -Successfully installed Python 2.7
Waiting for installers... /Successfully installed Visual Studio Build Tools.
8
  • 1
    Great, now I have multiple Python installs when all I wanted was VCBuild.
    – aroth
    Jan 5, 2018 at 0:51
  • Worked perfectly for me - running Windows 7 Enterprise
    – jBoive
    Jan 8, 2018 at 10:48
  • 2
    This solved part of the node-gyp problems, still missing "VCBuild" though.
    – s.meijer
    Jan 18, 2018 at 13:42
  • 7
    An additional choco install -y vcbuildtools fixed my build environment.
    – s.meijer
    Jan 18, 2018 at 14:03
  • 2
    Windows 10, works. Just takes so long you wonder is it stuck or not, keep waiting.
    – Syed Priom
    Apr 19, 2018 at 15:49
5

(This answer comes from comments above from @s.meijer. But I think it deserves to be an answer by its own.)

Run choco install vcbuildtools will install vcbuild that satisfies npm build needs on Windows.

0
2

I'm just posting this in case it saves anyone some time.

I tried all the answers I could find regarding this issue and they didn't work, ie:

// running powershell as administrator  
npm install --global --production windows-build-tools 

choco install vcbuildtools

The only thing that made "VCBuild.exe" errors go away was installing:

NET Framework 2.0 Software Development Kit (SDK) 

The installation was a bit weird, I ran the .exe file and nothing seemed to happen but, judging by the fact that the install error messages went away, apparently it worked and was installed.

1
  • 1
    Not sure if this really helped, but I'm going to vote up. Seems like windows-build-tools didn't fully help, and the .NET 2.0 SDK is silent (no UI) which is confusing. After 2-3 minutes, the rebuilding worked.
    – misha
    Jul 22, 2019 at 6:11
0

Looks like the answer was staring me in the face... You can't :-(

I found the steps to compile on the node-gyp Readme.md

It does in fact require VS2015 for Windows which sucks because

enter image description here

2
  • 1
    Ended up being 16GBs
    – Jackie
    Jan 29, 2016 at 15:20
  • VC++ on its own is >3GB though.
    – Nick Cox
    Feb 23, 2016 at 22:04
0

I got this error when I was trying to run an AngularJs application (requiring Node.js 6x) in an Node.js 12x env. Downgrading my version of Node.js made this go away. TIP: If you need to flip between Node versions, look at http://nvm.sh

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jul 4, 2022 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .