1

The problem is, Firefox window will not open when I try to start it. I can only see a process appear in the task manager, but no window will show up. It used to work fine but something, possibly an update, has broke it. Using Windows 7, Firefox 44.

Things I've tried:

  • Start it in safe mode with shift pressed: no impact, same behavior
  • Try to start profile manager using firefox.com -P: no impact, same behavior
  • Try to remove the binaries from C:\Program Files (x86)\Mozilla Firefox and reinstalling: no impact, same behavior when starting
  • Uninstalled Firefox using its own installer, then reinstalled: no impact
  • Removed my profile from C:\Users\myusername\AppData\Roaming\Mozilla\Firefox\Profiles: no impact, same behavior when starting
  • Removed my profile from C:\Users\myusername\AppData\Local\Mozilla\Firefox\Profiles: on first run after this complained about missing profile; reinstalling Firefox brought back to error behavior
  • Rebooted the computer: no impact
  • Run a Microsoft Security Essentials scan: no results
  • Checked for results in Event Viewer -> Applications, nothing interesting
  • chkdsk found no problems

After each test, I've also killed the firefox.exe process using task manager before trying something else.

I'm at loss. I have no more ideas what to try.


Edit: I've now opened a bug to bugzilla about this, as it seems to be an actual bug.


Edit 2: I should have mentioned that I've been using 32-bit version of Firefox on my 64-bit Windows 7. Switching to 64-bit Firefox also made the issue go away.

So as a summary, the problem seems to be that since Firefox 44, running 32-bit version of Firefox on 64-bit Windows 7 seems to work only if you run it as Administrator.


Edit 3: now the problem has had an interesting twist to it. My bug report has been closed, as according to them now that Firefox has released a 64-bit version of the browser, I should have just switched to that and by continuing the use of 32-bit version of Firefox this is expected. Because currently the default upgrade path will not switch to 64-bit, this would lead to hangs on any user not heard of 64-bit version, which is probably a lot of people. You are expected to "just know" that you need to switch to another version manually by uninstalling and going directly to the site to download a 64-bit version.


Edit 4: bug re-opened, we're working on it.

  • What software or updates have been installed recently and before this problem started to happen? – Ramhound Jan 28 '16 at 21:48
  • Have you attempted to use System Restore to go back to a date it was working? Have you uninstalled and reinstalled Firefox? Are there any error messages in Event Viewer? Is the system clean of viruses and malware? – CharlieRB Jan 28 '16 at 21:50
  • I haven't installed any software in a while, if you mean firefox extensions or plugins. The firefox version I tried installing (from scratch) was 44.0 (us-en). – eis Jan 28 '16 at 21:51
  • @CharlieRB I did remove the binaries from program files and reinstall it. (third bullet point) System restore I've yet to try. – eis Jan 28 '16 at 21:52
  • Only recent events in event viewer, applications section is two entries by "RestartManager", I assume from the time I restarted my computer. – eis Jan 28 '16 at 21:54
4

I have the same problem after updating to Firefox 44. The first launch is successful, but after closing that, Firefox does not start even if system has been restarted. Also Firefox does not open when clicking links in others programs (i.e. messenger). Firefox has a process running, but it does not open a window.

I solved the problem by installing the latest stable version 43. https://download-installer.cdn.mozilla.net/pub/firefox/releases/43.0.4/

We need to wait and hope that they will fix it in the next version.

  • As a comment, I would say I managed to launch Firefox 44 when executing as an admin. – Raph Petrini Feb 1 '16 at 7:17
  • @RaphPetrini for me as well. – eis Feb 1 '16 at 8:42

protected by Community May 4 '16 at 20:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.