0

I have a lingering problem after running a clean Windows 10 install (via Microsoft's Windows 10 media creation tool after the upgrade from Windows 8.1 failed.

It looks like the transaction resource manager is corrupted in some way and every repair I've tried has failed. The system event log is full of 136 and 137 messages (every 5 seconds):

Warning: The default transaction resource manager on volume C: encountered an error while starting and its metadata was reset.  The data contains the error code. 
1C00040002003000020000008800048000000000060019C000000000000000000000000000000000060019C0
Error: The default transaction resource manager on volume C: encountered a non-retryable error and could not start.  The data contains the error code.
1C0004000200300002000000890004C000000000010100C000000000000000000000000000000000010100C0

A couple of the other symptoms are:

  • Some Windows Updates are failing with error 0x80071a91. It seems to only be updates that change system components (and therefore rely on the Common Log File System). Windows Defender and Malicious Software Tool updates all install/run fine.
  • The Credential Manager service will not start with error 6801: Transaction support within the specified resource manager is not started or was shutdown due to an error

After various searches I have ...

  1. Run sfc /scannow (no errors)
  2. Run chkdsk /f (no errors)
  3. Run Dism /Online /Cleanup-Image /ScanHealth (no errors)
  4. Run fsutil resource setautoreset true c:\ and rebooted
  5. Rebooted in safe mode, deleted the *.blf *.regtran.ms and *.tm* files in %SystemRoot%\System32\SMI\Store\Machine and %SystemRoot%\config\TxR, rerun the fsutil command and rebooted
  6. Performed a clean boot to see if the problem still remains (it does)
  7. Run the Windows Update Troubleshooter in admin mode. It says that "One or more Windows Update components are configured incorrectly" and that it repaired it, however the problem still remains
  8. Reset the Windows Update components based on http://support.microsoft.com/kb/971058.

None of these have fixed it and I'm not sure what went wrong in the first place during the installation. Any further suggestions, or am I up for a third rebuild?

  • 1
    Where did your installation source files come from? Does your system have any exotic hardware? Does your memory pass a memcheck? – Hydranix Jan 29 '16 at 3:56
  • Source files came from MS ISO download to USB key. No exotic hardware - std HP Envy laptop. Memcheck passes – Rhys Gibson Jan 29 '16 at 5:46
  • 1
    I would say, try to download the iso file directly from techbench. That's the one I've used without trouble. (Scroll to bottom, select your Edition (probably "Windows 10"), download) microsoft.com/en-us/software-download/techbench – Hydranix Jan 30 '16 at 20:22
0

I tried another clean boot install from an ISO based on the TechBench link that @Hydranix noted in the comments. This installed correctly, but I still had all the same errors.

To fix it, I had to format the OS partition so that it was a completely clean install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.