1

I have an HP desktop computer running windows 10 which has stopped showing the start menu after automatic updates were installed.

When clicking on the windows logo, or tapping the windows key on the keyboard nothing happens. The corner menus also don't show when I drag the mouse pointer to the edges of the screen.

I'm using a local user account, this PC has no microsoft accounts.

I have tried a few solutions, with no success:

  • dism (DISM.exe /Online /Cleanup-image /Scanhealth ; DISM.exe /Online /Cleanup-image /Restorehealth) - reports no issues
  • sfc (sfc /scannow) - reports no issues
  • deleted c:\users\<user>\AppData\Local\TileDataLayer and rebooted
  • re-register apps (Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}) - stalls forever. Actually, running just Get-AppXPackage in powershell does nothing, just hangs, ctrl+c can't kill it.
  • create a new local user and login as it. the first login gets stuck forever at "we're preparing the stuff for you".
  • boot in safe mode, login, and restart
  • disabled firewall and antivirus

None of the methods have worked so far. I have also found that launching the settings application via explorer -> computer -> settings will cause explorer to lock up.

I'm really trying to avoid reinstalling windows without at least figuring out what has happened, since this may happen again.

  • Do you recall when this started happening? The start menu uses the package ShellExperienceHost quite extensively, so if Get-AppXPackage isn't working for you, this is probably somewhat central to the problem. You could try the command Add-AppxPackage -DisableDevelopmentMode -Register "C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\AppXManifest.xml", which only registers that one aspect and doesn't try and enumerate all packages. – Jonno Jan 29 '16 at 16:44
  • It started happening yesterday, not sure when exactly since I'm not the regular user of this PC. I have tried running that command, it prints the Deployment operation progress: C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\AppxManifest.xml Initialized message but never finishes. – André Fernandes Jan 29 '16 at 16:54
  • Some other instructions you could try: urtech.ca/2015/09/… – Jonno Jan 29 '16 at 18:27
  • I assume, by restart, you clicked Restart and not shutdown and manually start up the PC. Windows 10 puts itself in hybrid sleep so it never really shuts down untill one does a reboot – Ganesh R. Jan 29 '16 at 19:07
  • @Jonno did not try yet but it sounds like it won't work. I can't login to newly-created accounts, and have already tried deleting the tiledatalayer database with no results. – André Fernandes Jan 29 '16 at 23:24
0

Any change after you end Cortana?

Task manager-->Processes-->Backround Processes-->End Cortana.

  • There is no cortana under background processes in task manager. – André Fernandes Jan 29 '16 at 16:51
  • 1
    imgur.com/DRbzubg – Kenneth Goodwyn Jan 29 '16 at 20:44
  • @Ramhound If one has Windows 10 version 1511, they will have Cortana proces running in the background – Ganesh R. Jan 30 '16 at 5:50
0

To my dismay, after trying all of the solutions posted here and on various forums, the only thing that solved this problem was a full reinstall of windows 10 from Microsoft's installation media.

It seems that something got badly corrupted, it wasn't even possible to do a reset via the recovery console. At some point the PC got into a reboot loop where it failed to boot, then failed to repair itself, then fail to boot, and so on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.