I have a domain controller set up with some shared folders. I have multiple users with different levels of access to the shared folders. I tried to use the GPO to map the network drives and it didn't work. I then entered a domain administrator credentials in the GPO "connect as" box and the drive mapped.

On the client machine, when I login as the user I can manually navigate to the share location, \\server\sharedfolder\accessiblefolder, and have access to everything as I should. However, if I try to use the "net use" command or use the "map network drive" button, I get an error or a dialog box asking for credentials to the server.

It seems that the user doesn't have access to connect to the server, but still has access to the share. Does anybody have any suggestions? I don't want to make all the users admins in order to use network shares.

Update:
I think the problem is due to the users not having access to the root share folder. I intended for them to have only access to some of the folders that administrators have access to in the share. I decided to create individual shares for each folder inside the already shared folder and map directly to those shares. This worked as expected.

  • Sounds like you should give your users the permission to map network drives. – Ramhound Jan 29 '16 at 19:22
  • I never intentionally disabled it. Do you know where that setting is? – ultimoblaze Jan 29 '16 at 20:24
  • You were trying to create a share to a folder inside a root folder, the users themselves didn't have permission to? If you want to only provide read access to a share, make that its own partition, then create a second partition allowing the user's to have write permission to it. – Ramhound Jan 29 '16 at 20:32

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.