1

enter image description here

I bought this cheap (2$) IDE to SATA adapter, connected it to my IDE hard disk, my sata motherboard and power plug and it does not function. A red light is lit on the little board but it just delays or freezes my pc during boot. If I plug it in the motherboard after boot, the disk is still not recognized, not even in bios. I also tried setting disk jumper to "Cable Select" instead of "Master".

I use Ubuntu 14.04 and my dmesg shows these:

[   17.323227] ata6: exception Emask 0x40 SAct 0x0 SErr 0x80800 action 0x7
[   17.323232] ata6: SError: { HostInt 10B8B }
[   17.323237] ata6: hard resetting link
[   17.641012] ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   17.641028] ata6: EH complete
[   63.548729] ata6: exception Emask 0x50 SAct 0x0 SErr 0x4090800 action 0xe frozen
[   63.548733] ata6: irq_stat 0x00400040, connection status changed
[   63.548735] ata6: SError: { HostInt PHYRdyChg 10B8B DevExch }
[   63.548740] ata6: hard resetting link
[   64.272413] ata6: SATA link down (SStatus 0 SControl 300)
[   64.272425] ata6: EH complete

My motherboard is a Gigabyte GA-Z87X-D3H with SATA3 ports only and my hard drive is an IDE 250GB Seagate Barracuda.

Is the adapter defective or incompatible? Is there anyone who has used such an adapter successfully?

5
  • Unless you provide specifics we would only be able to guess at what the problem is. Unless the drive is your boot drive, you would want to set the drive to slave, not master anyways.
    – Ramhound
    Jan 29 '16 at 21:00
  • I will set it as "Slave" and update upon reboot.
    – John
    Jan 29 '16 at 21:02
  • 1
    Usually these types of adapters require the drive to jumpered as Master or CS, check the adapter documentation, not seeing them in BIOS can be normal though. Is the drive known to be good, because this looks like a drive or adapter failure.
    – acejavelin
    Jan 29 '16 at 21:06
  • I just tried "Slave" and it is still not recognized in bios, the pc also cant boot at at all. I waited 1 minute to see the bios screen. Same behaviour when set to "Master", only "CS" lets me boot and still no drive. The drive is ok, I tried it with an external IDE to usb adapter.
    – John
    Jan 29 '16 at 21:10
  • "Is the adapter defective or incompatible?" -- You've failed to include the possibility that you're not using it properly. The two SATA connectors are not identical, and the one you need to use depends on which interface has the disk.
    – sawdust
    May 25 '17 at 8:15
1

It might just be a cheap design. (The price is your first hint)

There are very good USB3-to-HDD cables available.

The best sets I have used include a separate power supply for the HDD, and connectors for 3.5", 2.5" & SATA drives. They can be found in the usual places.

Here is a good article describing the one I use now:

How to read old hard drives

0

After several attempts the adapter worked with disk jumper setting to "Master". Upon reboot sometimes it works, sometimes not. I conclude that it is a faulty adapter not an incompatible one. I 'll buy another... :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.