-1

AMD Phenom II X4 955, Reference GTX 460 1GB, Gigabyte SKT-AM3+ 78LMT-S2P Rev 5.1 Motherboard, 4GB DDR3, SSD+HDD, EVGA 500W PSU

My custom built PC, as above, has the very annoying issue of sometimes booting using the PCI-E graphics (GTX 460) and sometimes using the onboard (Radeon 3000) graphics, which can just about play Quake 2 at 60 FPS!

There is a workaround, but as I've built this for some non-tech savvy users, I want it to just work. The workaround is, if you unplug the PC from the wall for 10 seconds, usually but not always it will boot using PCI-E graphics. If I restart, it will not switch graphics cards. This means workaround 2 is to never shut it down. :(

I have tried to disable the integrated graphics entirely in the BIOS. This just caused the mobo speaker to play the long 'no video found - but I'll boot anyway' beep.

Any thoughts? Hopefully I won't have to replace the graphics card. I can confirm I experience no graphics issues once its booted. I have of course checked and reseated all connections.

  • Kinda sounds like the video card isn't always initializing quick enough... I would check for updated BIOS for the motherboard or updated firmware for the video card. You could also have a defective card, or one that just has a slight incompatibility with your setup... Although things are pretty much standardized in the industry in this area, incompatible combinations of hardware can occur. – acejavelin Jan 30 '16 at 18:04
  • I didn't know one could update a GPU's firmware. It seems though that I can't find one for a reference GTX 460 and I'm a bit nervous to flash it and make it think it is an OEM one. – drspa44 Jan 30 '16 at 22:34
  • Varies from card to card, some can be and some cannot, sometimes because OEMs do not release it. When you say "reference card" do you mean "generic"? In other words, not from a major manufacturer like EVGA, PNY, or Asus for example? Then no, do not flash a different BIOS, your "reference card" is likely just a generic one based on Nvidia's basic reference designs and often not licensed by Nvidia, not a REAL Nvidia reference card. – acejavelin Jan 30 '16 at 22:45
  • It has only Nvidia branding on it. It looks exactly like this: wccftech.com/images/news/Nvidia-GTX-460-pictured/… . I bought it used from a second-hand shop, so I don't know where it came from originally. – drspa44 Jan 30 '16 at 23:03
  • It's a generic one... I would only try the Nvidia firmware if you can find it. Other OEMs often have customization in the card or firmware. – acejavelin Jan 30 '16 at 23:05
0

In the BIOS, you should be able to set the Init Display First option to PEG which should prioritize the card in the PCIeX16 slot. See top of page 29 in the Gigabyte 78LMT-S2P motherboard manual.

If that doesn't work, and, as you say, disabling the onboard video in the BIOS (see page 22) causes a POST error, then there's likely a problem with the motherboard's PCIeX16 slot or channel. Some boards of this generation had such issues. In that case, try updating the BIOS to the latest version Gigabyte 78LMT-S2P BIOS updates.

If that doesn't work, the last thing to try is a different PCIe video card. If it doesn't work on another card either, then it's a defect in the motherboard and not much you can do.

  • I have checked Init Display First is set to PCI-E graphics. If it weren't I'd expect it to boot with integrated graphics every time. I'll try updating the BIOS. It worked fine previously with a gtx 970, so I'd be surprised if the motherboard is at fault. – drspa44 Jan 30 '16 at 14:01
  • If it was fine with a different card then it's a problem with the card. – Mekki MacAulay Jan 30 '16 at 17:07
  • I should have clarified: the mobo+gtx 970 worked fine, but I was using a different power supply at that time. Given it barely tops 300W, I doubt it is a PSU issue though. – drspa44 Jan 30 '16 at 22:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.