This is not a full duplicate of this question or this question, though the base question is the same. However, those questions have no answers.

For over a half a year I have problems downloading files with Firefox. Generally when I click on a download link, a download dialog is opened asking me what to do, save it or open it. Immediately, there is also an error/warning pop-up (twice, but I only can see one at first) with only an OK button. Which looks like this with the message :

"C:\Users\%USER%\AppData\Local\Temp\wBBDv9K8.zip.part could not be saved because the source file could not be read.

Try again later or contact the server administrator."

Replace '%USER%' with the name of the user trying to download.

After closing the pop-up, the download dialog disappears and I have to minimize Firefox and open it again, to see the other pop-up.

Downloading the exact same file with Internet Explorer does work, but is not desired.

I tried all solutions from here.
I tried all solutions from here.
I tried disabling extensions.
I tried fixing permissions on the temp folder.
I tried making all files and folder in the profile directory non-readonly.
I tried running firefox as administrator.
I tried disabling my firewall.
I tried "Save link as...".
I tried selecting a different downloads folder. (though it is clear that is not the problem)
I tried resetting firefox. (via about:support).
I tried clearing the setting "network.http.accept-encoding" in about:config.

The resetting seemed to work at first until I tried to update flash, which was the first occurence of the problem since the reset and after a few other downloads. The problem with updating flash is that you cannot save the file, because flash tries that himself.

Very rarely though, the downloading of a file does work and I do not receive the error message. However, this chance feels like 1 in 100.

On the moment of writing this question I am using firefox 44.0, but this problem is already a few versions old at least. Also, this problem did not occur before when using the same extensions.
In the meanwhile I upgraded from Windows 7 to Windows 10, but the problem still persists.

I am also able to ignore the warning and click on the download dialog and then click OK. This puts the download in some corrupt state which I cannot cancel. The only way to remove it is closing Firefox.

Current workaround:
After a download failed, I can go to the download library by clicking on the blue download icon. I can then click on the retry icon and the download succesfully finished. This only works however, when I click on the OK button of the dialog and therewith dismissing the download dialog.

I'm running out of options, what more can I try? Is it also possible to disable 'predownloading' by skipping the temp folder and directly download to my downloads folder, starting when I click on OK button on the download dialog?

  • Have you tried installing firefox as administrator (right click, Run as administrator) Jan 30, 2016 at 18:21
  • @JohnnyVegas good point, I'll try that.
    – Mixxiphoid
    Jan 30, 2016 at 18:22
  • 1
    Plus 1 for research. :)
    – Xavierjazz
    Jan 30, 2016 at 18:34
  • 1
    @Xavierjazz thanks :). It was a real pain though, putting all the facts together.
    – Mixxiphoid
    Jan 30, 2016 at 18:35
  • 1
    @JohnnyVegas the minor detail "as administrator" seemed to do the trick. Please post this as an answer and I will accept in 2 days. Just to have it tested a bit more.
    – Mixxiphoid
    Jan 30, 2016 at 18:37

1 Answer 1


Install Firefox as an administrator - Right click, Run as Administrator.

  • 3
    This answer would be more useful if it explained why. Jan 31, 2016 at 3:48
  • @RoddyoftheFrozenPeas Because Windows. You need a better reason? Jan 31, 2016 at 3:59
  • 1
    Personally, no. But a good answer would address why the OP's attempts didn't resolve the problem rather than a hand-wavy "magic" solution. Jan 31, 2016 at 4:05
  • @RoddyoftheFrozenPeas although I agree that the answer is a bit short. I don't know whether it is possible to prove what specific problem was fixed with this solution. On the internet there are many people asking this question and all have different solutions, with rarely an explanation why it is the solution.
    – Mixxiphoid
    Jan 31, 2016 at 8:15
  • Just a guess: On Windows, doesn't almost everything write at least something to the registry during installation or to somewhere else that isn't owned by a regular user? An install done without admin privileges couldn't do that and something is bound to go wrong - although you'd think the install itself would catch that as an error.
    – Joe
    Feb 3, 2016 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .