1

Running on Fedora 22, any time I want to install a package, e.g.:

$ sudo dnf install lshw
RPM Fusion for Fedora 22 - Free - Updates                                855 kB/s | 224 kB     00:00    
RPM Fusion for Fedora 22 - Nonfree - Updates                             504 kB/s |  52 kB     00:00
...    

dnf downloads updates from the repositories. It can be stopped by using this switch:

-C, --cacheonly       run entirely from system cache, don't update cache

Can this be made a default option somehow? I.e. I want to manually update the cache as needed via dnf check-update and dnf upgrade.

This is what I have so far:

  • I tried changing options that look related to metadata / cache updates per http://dnf.readthedocs.org/en/latest/conf_ref.html - metadata_expire=never, metadata_timer_sync=0
  • Disabled dnf-makecache timer (systemctl disable dnf-makecache.service)
  • I don't have dnf-automatic installed

I could not find anything else that would help. Any ideas?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.