1

I followed this tutorial on installing an SFTP/SSH server on Windows, but I am having problems trying to connect to it. When using either PuTTY or WinSCP, I get the error "Network error: Software caused connection abort."

I had read that such errors are often caused by the server not being running (which I already checked), or problems with firewalls. The SSH server is behind a router, but I had already forwarded port 22 to this machine. I had also already made a firewall exception on the server for TCP connections on port 22.

I tried the top three solutions on this page. None of the worked, and I believed the problem experienced by the person who posted this question was different from my own; I cannot even connect for a while.

Oddly, it appears that FileZilla works better. I am able to establish a connection (I followed these steps), but the directory listings do not work properly (despite the fact that FileZilla displays 'Directory listing ... successful!") and give empty directories.

Is there anything else I can try (on either side) to fix this problem?

  • Can you connect from the server's machine? Show us FileZilla log (a real log file, not the message log from GUI), WinSCP session log and PuTTY event log. – Martin Prikryl Feb 1 '16 at 6:48
  • @Martin Prikryl No, oddly enough, I cannot even connect from the server's machine. – fakedad Feb 1 '16 at 7:03
  • Well, that's a more important information than most of the details in your question. Please update your question accordingly. + the logs. – Martin Prikryl Feb 1 '16 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.