5

I play an old MMO game that is made using 16-bit color. The game works perfectly on Windows 7 and old versions (Vista, XP).

However, the game has some bugs on Windows 8 and later versions.

I can start the game and play normally in full-screen mode, but when I minimize (alt tab) the game and then maximize again, the game graphics becomes purple and shrunk to half the screen.

Screenshot 1

Screenshot 2

I tried to use the "ChangeDisplaySettings" API but it doesn't work when I try to change to 16 bit per pixel.

Another strange note is that the game works like a charm on start. The bug occurs just when I minimize and then maximize again.

Does anyone have a solution to fix it?

  • Can you set the game compatibility mode to run in, say, XP SP3? – Kinnectus Feb 1 '16 at 13:11
  • Sounds totally unrelated, but somehow it fixed some older games - Try going to Task Manager and killing explorer.exe before going back into the game. Before they released AoE2-HD, I had to set up a batch file to kill explorer before opening the original game, then re-running it once the game finished. No idea why. – Jonno Feb 1 '16 at 13:20
  • Note to close voters: the part in the help center about video games being off-topic applies to questions about gameplay, not compatibility things like this. I'm voting Leave Open. – Ben N Feb 1 '16 at 17:17
  • @Jonno, I tried to kill explorer.exe before going back into the game, but no success. Same problem. – paulohr Feb 1 '16 at 17:21
  • @BigChris Compatibility mode doesn't work. Same problem. – paulohr Feb 1 '16 at 23:12
2
+50

There are applications, which allow running such full-screen DirectX games in a window. This can make the game to run slower, but it will allow to switch between the game and other applications without the graphics issues you describe.

One such application is DxWnd.

Below, I'll describe how to set up the GunBound Thor's Hummer (I think your screenshots are from this game).

The GunBound Thor's Hummer uses Launcher.exe to run the GunGame.gme file (these files are in the GunBound Thor's Hammer installation folder). I failed to setup DxWnd to handle the gme-file directly, so there are some additional steps needed.

  1. Copy the GunGame.gme to GunGame.exe.
  2. Replace GunGame.gme with GunGame.exe in the Launcher.exe file using some hex editor (Notepad++ will also work, while the standard Windows Notepad will corrupt the executable). You may want to backup the Launcher.exe before patching it.
  3. Run the DxWnd as admin.
  4. In the DxWnd select Edit > Add and enter the following values in the opened dialog:

    • Name: anything you want
    • Path: C:\Program Files (x86)\GunBound Thor's Hammer (nos)\GunGame.exe (replace with your actual path).
    • Launch: C:\Program Files (x86)\GunBound Thor's Hammer (nos)\Launcher.exe (replace with your actual path to the patched launcher).
    • All other options left with their default values.
  5. Press OK.

  6. Run the created item in the DxWnd window. The game will run in a window.
  • Hi Alex, yes, I know about the window mode, but I really want to solve this problem at full-screen. Thank you – paulohr Feb 12 '16 at 9:56
  • Full-screen window then maybe? ) – Alex Che Feb 12 '16 at 19:15
2

Since Windows 8, the Desktop Window Manger (DWM) is always on and runs Windows in 32Bit color depth all the time. This can cause such strange issues.

If applying XP compatibility mode (which activates shim that let games think they run at 16Bit color depth, while Windows still uses 32Bit) doesn't work, setup a Virtual Machine and use older Windows version like Windows XP (but without Internet connection) to run such really old games.

  • Hi @magicandre1981, unfortunately setup a VM is not an option. So there is no solution? Is not possible to disable the DWM with a kernel-mode software (driver)? – paulohr Feb 12 '16 at 17:40
0

Try running the program in compatibility mode, right-clicking (one of the sections; I use Linux now) and selecting 16-bit compatibility mode, or similar. Also select run using Windows XP, or any other OS than Win 8.

  • Hi @Thelolguy, also doesn't work. – paulohr Feb 12 '16 at 17:38
0

Things to try :

  1. In the game's Properties, Compatibility tag, in addition to setting XP mode, set also "Reduced color mode" to 16-bit. You could also try "Run in 640 x 480 screen resolution" and "Disable display scaling on high DPI settings".

  2. Right-click the program's executable file, typically an EXE, and click "Troubleshoot compatibility." Click "Try recommended settings" and "Test the program…" If the program now works, click "Yes, save these settings for this program". Else click "No, try again using different settings" and answer the questions until you find something that works or you give it up.

  3. If your video card is Nvidia, go to the Nvidia Control Panel -> Display -> Adjust desktop size and position -> Scaling, click Full-Screen and Apply.

0

Download the Windows Assessment and Deployment Kit and install the Application Compatibility Toolkit. Then try enabling one or more Compatibility Fixes for your game. There are several fixes (“shims”) available whose names hint at solving issues related to 16‑bit colour compatibility, but the process may require some trial and error since there is little or no explanation about exactly what most of the fixes do, how they work, or whether they are likely to have any effect at all in the configuration you’re using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.