3

Workstation 12 Pro - 12.1.0 build-3272444 Individual license Guest OS : Ubuntu 14.10 64-bit VMware Tools: 9.6.2.31837 (build-1688356)

VM works fine except... Updating VMware Tools, download stage issues a message and aborts:

Error: There was a problem updating a software component. Try again later and if the problem persists, contact VMware support or your system administrator.

I cannot find a useful resolution to this issue online. Perhaps this community can help work out a solution? I wonder if there's a VMware Tools install log file somewhere that could give me a clue as to the "problem" mentioned in the error message.

By the way, I also have an Ubuntu 15.10 64-bit VM which successfully runs VMware Tools 10.0.1.357 (build-3160059). I need to run the two versions of Ubuntu for software compatibility reasons.

3

Steps to recover from this error:

  1. On your host computer, browse to CDS Repository - /var/www/public/stage/session-59/cds/vmw-desktop/ws/12.1.0/3272444/windows/packages

  2. Download the file tools-linux.tar

  3. Unzip the file (I used 7zip, but any unzip tool should work). This will extract the file VMware-tools-linux-10.0.5-3228253.iso

  4. On VMware Workstation, mount the extracted file to the Ubuntu VM: a) Ensure the VM is running b) On the Workstation menu, select VM > Removable Devices > CD/DVD (SATA) > Settings... c) Click Browse, and find the file you extracted in step 3 above. Click OK. d) Select VM > Removable Devices > CD/DVD (SATA) > Connect

  5. The iso file will mount and open as a folder on the Ubuntu machine. On that machine, right-click the file that ends in .tar.gz, and select "Extract to...". Select Desktop and click "Extract"

  6. Open the Terminal app (Search > Terminal). Type this command: cd Desktop/vmware-tools-distrib

  7. Uninstall any older version of Tools with this command: sudo bin/vmware-uninstall-tools.pl

  8. Install the new tools: sudo ./vmware-install.pl -d

  9. Restart Ubuntu

That should be it!

| improve this answer | |
-1

I ran into a similar issue when trying to install the VMWare tools on a guest windows operating system after a Fedora version upgrade (to 22 I think). Following the updating tools promts gave the same error. The error may have been due to some network contraints. Downloading the appropriate .iso, mounting to the cd and installing from the image with in the guest operating system worked for me (as opposed from trying to download and install the tools using the gui/promts). If the updating of the tools was done on an another network or connection, it would likely work.

| improve this answer | |
  • The question wanted to update the tools not installing them, maybe you could reword and add to answer – mic84 Jul 17 '16 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.