2

How can I disable a schedule task in Windows 10? They suggested me to use /disable but apparently and that option is already gone in Windows 10 and was available in the previous versions of Windows.

>schtasks  /?

SCHTASKS /parameter [arguments]

Description:
    Enables an administrator to create, delete, query, change, run and
    end scheduled tasks on a local or remote system.

Parameter List:
    /Create         Creates a new scheduled task.

    /Delete         Deletes the scheduled task(s).

    /Query          Displays all scheduled tasks.

    /Change         Changes the properties of scheduled task.

    /Run            Runs the scheduled task on demand.

    /End            Stops the currently running scheduled task.

    /ShowSid        Shows the security identifier corresponding to a scheduled task name.

    /?              Displays this help message.

Examples:
    SCHTASKS
    SCHTASKS /?
    SCHTASKS /Run /?
    SCHTASKS /End /?
    SCHTASKS /Create /?
    SCHTASKS /Delete /?
    SCHTASKS /Query  /?
    SCHTASKS /Change /?
    SCHTASKS /ShowSid /?

I doubt delete will actually disable it.

How can I do that then?

UPDATE:

I need to do this only by the utility schtasks

3
  • Have you tried the (seemingly) deprecated /disable switch?
    – Kinnectus
    Feb 2, 2016 at 14:45
  • "They suggested me to use /disable" Who's "They"? "that option is gone in Windows 10 and was available in the previous versions of Windows." Schtasks in Windows 10 works exactly the same as it did in 7 and 8 (as far as /disable is concerned anyway), so I'm not sure who gave you the info about how to use the /disable switch, but they're wrong -- see Doenoe's answer for proper usage (on all Windows versions). Feb 2, 2016 at 16:26
  • I was wondering by the way why you only want to use schtasks.exe instead of powershell?
    – doenoe
    Feb 2, 2016 at 16:30

3 Answers 3

8

Use Powershell!

Disable-ScheduledTask -TaskName "Adobe Flash Player Update"



TaskPath                                       TaskName                          State
--------                                       --------                          -----
\                                              Adobe Flash Player Updater        Disabled

EDIT:

with the use schtasks.exe:

schtasks.exe /change /tn "Adobe Flash Player Updater" /disable

SUCCESS: The parameters of scheduled task "Adobe Flash Player Updater" have been changed.
3
  • i've updated my question.
    – Oskar K.
    Feb 2, 2016 at 14:58
  • editted my answer. ;)
    – doenoe
    Feb 2, 2016 at 15:06
  • I've run the command to disable a task and it said "ERROR: The specified task name "....." does not exist in the system." I took its name from ComputerManagement -> Task Scheduler
    – Oskar K.
    Feb 3, 2016 at 5:49
4

GUI:

  1. Open the "Task Scheduler"
  2. Open "Task Scheduler Library" -> "Microsoft" -> "Windows", "Application Experience".
  3. Disable "Microsoft Compatibility Appraiser" with a right-click choice.

CMD:

schtasks /Change /Disable /TN "Microsoft\Windows\Application Experience\Microsoft Compatibility Appraiser"
0

Easiest way is to use the Task Scheduler MMC snap-in. You can type "Task Scheduler" in the Cortana search box or run mmc.exe and add the snap-in manually. Once you get the GUI, just right-click on the task and choose "disable" - it's still there, just hidden :) I'm not sure why the command line has changed - weird...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .