2

I have a computer (one of the Gigabyte Brix) running Windows 7. I don't actually need to hear any audio out of it, but some of the software I need to run doesn't work if it can't open an audio output device. With headphones plugged into the headphone jack it works, but with them unplugged the sound device is listed as disconnected and acts as if there is no audio device. The hardware is still there, so is there some way to just tell it to ignore whether speakers are plugged in and always enable that jack? I'd rather not have rely on leaving a cheap pair of earbuds plugged in.

3

Disable automatic jack detection by following the instructions in this thread. Relevant excerpts:

  • Open regedit with administrator privileges
  • Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\GlobalSettings
  • Change the value EnableDynamicDevices to zero.
  • Reboot

EDIT BASED ON COMMENT:

If the registry approach doesn't work, you have two other options:

1) Set the option in the Realtek Control Panel (should be available with latest Realtek drivers for the sound card). Step by step details with images can be found at this website. Relevant excerpts:

  • Go to Control Panel -> Hardware & Sound -> Realtek HD Audio Manager
  • Click the yellow folder icon in the top right of the window
  • Disable front panel jack detection and auto popup dialog, click ok.
  • Click on device advanced settings at top right of window
  • Check the buttons for make front and rear output devices plaback two different audio streams simultaneously and tie up same type of input jacks..., click ok.
  • Open the speaker tab
  • Click on the green active speaker icon (should be under back panel on right side)
  • Click set default, click ok.

2) Replace the Realtek drivers with Microsoft HD Audio driver. Details can be found at this website. Relevant excerpts:

  • Uninstall the Realtek audio drivers and reboot
  • Open the device manager
  • Under Sound, video and game controllers, right click on High Definition Audio Device and click Update Driver software
  • Click Brows my computer for driver software
  • Click Let me pick from a list of...
  • Choose High Definition Audio Device
  • Click yes when warning pops up.
  • Finish confirming dialog windows and reboot
  • That's definitely the kind of answer I was looking for. Unfortunately it doesn't seem to have had any effect for me. – sparkyb Feb 2 '16 at 20:27
  • 1
    My Realtek HD Audio Manager doesn't have the "front panel jack dectection" option because this teeny PC has only one audio jack, a hybrid speaker/headphone/microphone jack. I could have tried upgraded that driver in case I didn't have the latest version, but I just went with option 2 and switch it to the Microsoft driver. I expressly don't care about hearing the sound (since I'll have nothing plugged in) so I don't really care if it is a worse driver. With the Microsoft driver, then the registry setting worked perfectly. – sparkyb Feb 4 '16 at 19:45
1

If for some reason you can't disable the jack detection via software, keep in mind that the detection is done by a mechanical switch inside the jack.

Cut the plug off a set of unneeded headphones, and plug it into the jack to activate the switch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.