6

I'm accessing a remote Windows computer via my Chromebook, using Chrome Remote Desktop. Is there any way to configure the computer such that the display will be turned off, but it won't go to sleep when I use it remotely?

I've tried using NirCmd following the suggestions of this post, but it doesn't seem to be working. When I run nircmd monitor off, the screen shuts off for a split second and immediately comes back to life.

Any help would be appreciated, thanks!

2
  • You could use logmein I read that they have a stable version for chromebooks just a suggestion you can black out the screen while using it. Feb 3, 2016 at 5:25
  • As far as I can tell, chrome remote desktop cannot do this. However, TeamViewer has this ability.
    – z7r1k3
    Feb 3, 2016 at 5:26

4 Answers 4

7

On windows chrome remote desktop, access remote machine and don't display at remote:
First option is turn off the monitor of remote machine manually of possible.
Second option is to Enable Curtain Mode for Chrome Remote Desktop, see further instructions here: Google support.

1

Open the command prompt as an administrator and paste below and press Enter.

reg add HKLM\Software\Policies\Google\Chrome /v RemoteAccessHostRequireCurtain /d 1 /t REG_DWORD /f && reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal && Server\WinStations\RDP-Tcp" /v SecurityLayer /d 1 /t REG_DWORD /f && reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp" /v UserAuthentication /d 0 /t REG_DWORD /f && net stop chromoting && net start chromoting

See Enable Curtain mode for Chrome Remote Desktop at https://support.google.com/chrome/a/answer/2799701?hl=en

0

I had the same requirement. I found the following answer which works for a linux host. It just turns the screen off but doesn't lock it. Which means anyone can press a key to wake it up.

xset dpms force off

How to turn off screen with shortcut in Linux?

0

Fyi. The code above is incorrect with "HKLM\SYSTEM\CurrentControlSet\Control\Terminal && Server\WinStations\RDP-Tcp"

The correct code as pasted from https://support.google.com/chrome/a/answer/2799701?hl=en

reg add HKLM\Software\Policies\Google\Chrome /v RemoteAccessHostRequireCurtain /d 1 /t REG_DWORD /f && reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp" /v SecurityLayer /d 1 /t REG_DWORD /f && reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp" /v UserAuthentication /d 0 /t REG_DWORD /f && net stop chromoting && net start chromoting

However after this registry update the Remote session terminates immediately, and what worked was to update the registry HKEY_LOCAL_MACHINE\Software\Policies\Google\Chrome\RemoteAccessHostMatchUsername to 0

1
  • Instead of commenting on an error in another post edit the post.
    – somebadhat
    May 25, 2020 at 8:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.