0

I'm trying to install and boot kernel-ml (currently 4.4.1-1) on RHEL 7.2 following the instructions here: http://linuxg.net/install-kernel-4-x-on-enterprise-linux-7-centos-7-and-rhel-7/

Install works fine and on reboot I can choose the new kernel from the grub menu - however it fails midway through booting up.

When it fails, I can see multiple instances of the following:

dracut-initqueue[632]: Warning: dracut-initqueue timeout - starting timeout scripts

Followed by this:

dracut-initqueue[632]: Warning: Could not boot.
dracut-initqueue[632]: Warning: /dev/mapper/vg_root-lv_root does not exist
dracut-initqueue[632]: Warning: /dev/vg_root/lv_root does not exist
Starting Dracut emergency shell...

I can still boot into the previously working old kernel, and to another 4.x (4.3.3-1) without issue, but 4.4.1-1 fails at this point every time. SO far I've tried the following with no success (some of the iseda come from https://askubuntu.com/questions/567730/gave-up-waiting-for-root-device-ubuntu-vg-root-doesnt-exist which looked like a similar error):

Exiting the dracut emergency shell - boot does not progress any further

Specifying root volume by UUID in the grub config - still not found

Checking if lvm2 is installed - it is

ls /dev/mapper - all I see under here is "control"

Added all_generic_ide boot parameter - no change

Rebuilt the initramfs for the broken kernel - no change

Removed rhgb and quiet from boot params

listing disks with lvm pvdisplay / lvm lvdisplay / lvm vgdisplay - none found, blank output

I'm not sure what else I can try here or what to do next - any pointers appreciated

  • Did you find a way out? I'm having exactly the same problem. – chirag1992m Jun 16 '17 at 21:22
0

I encountered this same problem on Ubuntu, the same scenario: 4.3.3 works but 4.4.x+ does not. The same thing was happening that no drives were found at all under /dev/mapper.

In my case, the problem wasn't with lvm (although I thought that was the issue as well), but that my computer uses a NVMe solid state drive (a Dell XPS 9550). According to Arch Linux Wiki, the location of the "nvm" driver was moved in between kernel 4.3 and 4.4. Some OSes have yet to update their initramfs to accommodate for the new location (including Arch and Ubuntu), causing the kernel to build without it.

See this bug in the Ubuntu queue: nvm extension is not properly loaded in initramfs.

The Arch Wiki suggests:

Edit your /etc/mkinitcpio.conf file:

...
MODULES="... nvme"
...

Then update the bootloader.

# mkinitcpio -p linux

But as Ubuntu doesn't have mkinitcpio to fix the problem as recommended in the Arch Wiki, I loaded the nvm extension in /etc/initramfs-tools/modules:

sudo bash -c "echo '
nvme' >> /etc/initramfs-tools/modules"
sudo update-initramfs -u -k all

If you have an NVM drive, you may also be running a Skylake chipset. If so, you should also download the i915 drivers and add the i915 extension to this same file, as recommended in https://askubuntu.com/questions/717338/installing-4-4-rc7-kernel-yields-i915-module-not-available

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.