8

How can I increase the maximum number of items that appear on a Windows 10 jump list, and is there any way to set separate maximums for recent and pinned items?

I use Remote Desktop to connect to multiple different machines. On Windows 7, once I had connected to a machine, it appeared in the jump list for the Remote Desktop. I could then pin it, and I had many of them pinned. You can adjust the maximum number of entries in the jump list, both for recent items and for pinned items.

In Windows 10, although you can pin items, the maximum number of items on the list is a combined maximum, not separate maximums for recent items and pinned items. This means that the more items I pin, the fewer recent items I see. In Windows 7, pinning items did not reduce the number of recent items.

The setting for this that existed in Windows 7 (see How can I increase the size of the pinned jump list in Windows 7?) has either been removed from Windows 10 or relocated somewhere else.

Windows 10 Taskbar and Start Menu Properties

I'm using the RTM version of Windows 10 (Build 10240).

  • Just change the number in Taskbar and Start Menu Properties under Start Menu – Ramhound Feb 3 '16 at 16:49
  • 1
    @Ramhound That's the problem. The Start Menu tab doesn't exist in Windows 10. I've edited the question with a picture of the dialog you are referring to. – Scott Feb 3 '16 at 17:10
  • Its a registry hack to get it done...tenforums.com/general-discussion/… – Moab Feb 3 '16 at 18:42
  • 1
    @Moab As stated by someone on that thread, that registry setting doesn't do anything on Windows 10. I just tried it and had the same result. – Scott Feb 3 '16 at 20:07
11

The fix: (guide with screenshots)

  1. Click "Windows key"
  2. Type/run regedit
  3. Find folder: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced
  4. Right click folder Advanced
  5. From the Edit menu, Select New > DWORD (32-bit) Value
  6. Rename new key to: JumpListItems_Maximum
  7. Right click and select Modify...
  8. Change value to desired value (e.g. 15 or 20) and select Decimal
  9. Click OK button to save

Further notes

When I did above, no restart was required. Some claims you need to reboot to ensure it's working, but never experienced a reboot was required.

I personally prefer 19 as value (my FullHD screen will add scroll for higher number). Default value is 10.

Edit: Added link to guide with screenshots

  • This fix no longer works in the latest version of Windows 10. I am using Windows 10 (Build 10240). If this becomes available in a later version of the build please post a comment. – BarrieK Sep 19 '16 at 7:31
  • 1
    It works for me with Windows Insider program, build 14926 (fast ring - as we speak). I applied it first time build +12000, so functionality should come back for ya. – Nick Niebling Sep 20 '16 at 7:07
  • 1
    Windows 10 (Home) x64, anniversary update (version 1607) installed today. This worked for me. The jump list is scrollable with the middle mouse wheel. Nice. Thanks @NickNiebling – user38537 Sep 30 '16 at 23:43
  • worked without restart in windows 10 32 bit. thanks – saber tabatabaee yazdi May 30 '19 at 20:50
0

Thank you all... It really works BUT Only if you open the registry editor as an Administrator... Atleast in my case, I tried a lot of times, I tried some variations also (like 32 / 64 bit Dwords, etc.). None of them worked. Finally it did after I followed the above mentioned Procedure as an Administrator. Steps to do it as an Administrator : Very Easy

Click on start or search button (Left bottom of screen) Or simply press windows button on the keyboard. Type regedit (Mostly typing only reg will do) Right click on the Blue icon with name Registry editor and click on RUN AS ADMINISTRATOR.... Rest do as above...

This works for sure

Thank you all Once again

-2

To change quantity of Jump List items:

  1. Open RegEdit and navigate to: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced
  2. Click on Advanced key.
  3. On menu, click Edit -> New -> DWORD (32 bit) Value.
  4. Right-click it, select Modify and set to what you want. I set mine to 30 and it actually took effect immediately without a reboot.
  • 1
    As mentioned by others, this hack doesn't work on Windows 10. You also forgot to show the key name when you copied the information. As a final note, it's always a good idea to cite your source. – Julie Pelletier May 29 '16 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.