2

My keyboard's media keys recognize Grove Music as standard media player and I can't change it. I'am using "Logitech Options" manager, because "SetPoint" manager not compatible with this keyboard. I try this options:

  • Uninstall "Groove Music", but it not work. After media key pressed it automatically installed again.
  • Force assigning application to media key, but other buttons: Rewind, Play/Pause and Forward still assigned to "Grove Music".
  • I try to change extensions ".cda", and AudioCD default media player to mine preferred (AIMP), but still not working.
  • Of course i changed default media, audio, video player in windows settings, but media keys always assigned to "Groove Music".
  • Found only option do not use "Logitech Options" and mine preferred player assigning to media key, but other applied options lost.
0

Go to 'services' (services.msc). Stop and restart the 'Human Interface Device Service'. It works for me Windows 10 V1703.

0

Have the same issue with the Logitech K780 keyboard. WORKAROUND I found is to uninstall Logitech Options. Works perfect after that (all config from the Logitech Options will be lost, but at least I can use the media buttons)

Anyway still waiting for an official fix by Logitech so I can use the tools from Logitech Options: I made a complain: https://community.logitech.com/s/question/0D55A00007M01K5SAJ/keyboard-media-keys-force-assigned-to-grove-music-windows-10-and-logitech-k780

Not the answer you're looking for? Browse other questions tagged or ask your own question.