1

Not a duplicate. I'm only adding this after trying out everything in other questions

I recently copied a folder from a friend onto my HDD, and I'm now unable to delete the folder. ( No error message shows up. I select the folder and hit delete, and nothing happens )

I tried the following:

  1. Using the regular command line delete option ( del folder )

  2. Using the commands given in the following thread:

    Windows Unable to Delete ._. File del "\?\F:\folder"

  3. I couldn't use FileAssassin as there are no files inside the folder.

  4. I tried using Erase (the "erase on restart" doesn't work. When I try to erase instantly or manually, it stops and windows shows me that the program has started working.) When I tried right clicking on the folder and then clicking on erase, it asks me if I'm sure and then when I hit yes, nothing happens. I couldn't "Secure Move" it either

  5. I tried changing the permissions of the folder - I couldn't change it. Error Message: "Failed to enumerate objects in the container. Access is denied"

  6. Tried moving the files into my laptop and then deleting it. ( Unable to move )

The folder is empty. It's a game folder. The folder list goes as follows: gmW >> cstrike >> sound >> (this goes into the problem folder. It is because of this folder that I'm unable to delete the whole thing. When I try to open this folder, it shows error message: The file or directory is corrupted and unreadable )

I understand that formatting the HDD is an option. The problem is that it has over 800 GB of data and I can't copy the onto my laptop (storage is not sufficient) I don't have any other hard drives either.

I scanned for viruses (Kaspersky) and there are none. The size of the folder is 0 bytes.

Is there any way to get rid of this file without formattting? Also, what could be the problem here.

  • Have you tried running chkdsk? – DavidPostill Feb 3 '16 at 23:18
  • Okay, I just ran chkdsk and tried deleting the folder. Thank you! And sorry if this was something too trivial to ask here. – WorldGov Feb 3 '16 at 23:23
  • It worked? You were able to delete the folder? – DavidPostill Feb 3 '16 at 23:24
  • 1
    Yes, it worked like a charm. I ran chkdsk and it told me that it discovered errors in certain indices of the HDD. And so I ran the chkdsk /f F: command to fix the drive. There was freespace marked as allocated, and some "orphan files" ( don't know what that means). It completed the re-allocation and I was able to delete the file. – WorldGov Feb 3 '16 at 23:28
  • 1
    Great! Just so you know the clue for me was "The file or directory is corrupted and unreadable" ;) – DavidPostill Feb 3 '16 at 23:48
1

( Adding an answer just to mark this question as solved )

As suggested by @DavidPostill, I tried running chkdsk on my HDD. Once I did that, it told me that there errors in certain indices of the file.

And so I ran a chkdsk /f F: command to fix the drive. I was then able to delete the folder.

CMD Screenshot

0

Use rmdir /S <dirname> from a command prompt opened with admin privileges.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.