5

I had several thousand files open in a Sublime Text project and those files were modified outside of Sublime so it started prompting me whether or not I wanted to reload the file or cancel. But if I hit Cancel it continues to display the same prompt for every file. I tried to force quit Sublime but when I relaunch it, it relaunches with the same files open and again it begins to prompt me about reloading the files. I would literally have to sit here holding down the Enter key for hours to get all of these prompts to pass..

enter image description here

1

I solved my problem by manually deleting the files that Sublime Text saves session data to.. These files were

~/Library/Application Support/Sublime Text 3/Local/Auto Save Session.sublime_session
~/Library/Application Support/Sublime Text 3/Local/Session.sublime_session

1

There's a setting you can apply in ST3 to disable the prompt for auto-reloading:

{
    "always_prompt_for_file_reload": false
}

Go to Preferences > Settings, and merge the above into your settings JSON. Note, this setting does not prevent the files from reloading, it just stops asking you about it. There is currently no setting to completely disable the auto-reload.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.