0

I have installed two Windows 8.1 os and Debian on my Device. I use Grub2 EFI to boot between Debian and Windows. After choosing Windows via Grub menu The Metro Boot manager appears.

I have configured Metro boot loader via bcdedit.

Look at the following configuration:

Grub2EFI:

*menuentry 'Windows Boot Manager' --unrestricted --class windows --class os $menuentry_id_option 'osprober-efi-5E19-32AF' { insmod part_gpt insmod fat set root='hd0,gpt2' if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 5E19-32AF else search --no-floppy --fs-uuid --set=root 5E19-32AF fi chainloader /EFI/Microsoft/Boot/bootmgfw.efi }

Windows BCD:

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\ubuntu\shimx64.efi
description             Windows Boot Manager
locale                  en-GB
inherit                 {globalsettings}
integrityservices       Enable
default                 {current}
resumeobject            {7c17a612-62c5-11e5-bdcc-ce4422da7a40}
displayorder            {current}
                        {7c17a619-62c5-11e5-bdcc-ce4422da7a40}
toolsdisplayorder       {memdiag}
timeout                 15


Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 8 
locale                  en-GB
inherit                 {bootmgr}
recoverysequence        {7c17a614-62c5-11e5-bdcc-ce4422da7a40}
integrityservices       Enable
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {8da69470-cb35-11e5-8341-806e6f6e6963}
nx                      OptIn
numproc                 2
bootmenupolicy          Standard
usefirmwarepcisettings  No

Windows Boot Loader
-------------------
identifier              {7c17a619-62c5-11e5-bdcc-ce4422da7a40}
device                  partition=\Device\HarddiskVolume6
path                    \Windows\system32\winload.efi
description             Windows 8 for work
locale                  en-GB
inherit                 {bootmgr}
recoverysequence        {7c17a614-62c5-11e5-bdcc-ce4422da7a40}
integrityservices       Enable
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=\Device\HarddiskVolume6
systemroot              \Windows
resumeobject            {7c17a612-62c5-11e5-bdcc-ce4422da7a40}
nx                      OptIn
numproc                 2
bootmenupolicy          Standard
usefirmwarepcisettings  No

When I choose the first Windows 8, then Windows is starting/logging immediately. When I choose the second installation of Windows the device is rebooting, then I have to choose Windows on Grub menu again.

Is it possible to boot from two Windows installations without rebooting using Metro Boot Loader?

I have to use Metro boot loader in this case because I need touch screen. On Grub menu Windows is starting automatically after 15 second. It is uncomfortable to choose another Windows and wait long time (rebooting and 15 second on grub).

Do You have any ideas?

  • You should add your grub boot settings too – conquistador Feb 4 '16 at 13:57
  • Hello. I have added. – Michald86 Feb 4 '16 at 14:13
  • you can use EasyBCD to add a new entry in Metro Bootloader that points to same target as your grub's entry for Windows ("/EFI/Microsoft/Boot/bootmgfw.efi" in your case) – conquistador Feb 4 '16 at 14:27
  • Does not wok. The device is restarted. Grub appears. After choosing Windows Boot manager "Automatic repair" appeard – Michald86 Feb 4 '16 at 15:27
  • When I changed Windows Boot Manager to legacy bcdedit /set {default} bootmenupolicy legacy Two Windows 8 systems starts immediately. But touch screen does not work :( – Michald86 Feb 4 '16 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.