3

I'm running Ubuntu and I have a strange issue where any new window I open (open office doc, pidgin window, etc) open behind current Windows.

this is frustrating, especially for IM windows as I often don't see the window.

Has anyone ever had this issue, and know how to resolve it?

1

Check if the window that stays on top of others have stay on top checked. If so, uncheck it. You can check this by right-clicking the top bar.

  • Actually this seems to affect the behavior of how other windows open as well. I experience this on Gnome 3, Ubuntu 16.04 if I have one browser window that is "always on top". – bohrax Oct 14 at 8:17
1

This is metacity's default behavior at times (I certainly haven't found a pattern to it yet...). If you want to have new windows disrupt your current work then you'll need to switch to a different window manager. Either of Xfwm or KWin will do.

0

The placement of new windows is determined by the window manager and you can probably configure it in several different ways. Check if you have inadvertently have changed the configuration to behave like that.

Configuration will be different depending on your window manager.

0

Here is the answer https://askubuntu.com/questions/162757/why-some-windows-in-ubuntu-12-04-opens-in-background
You should set Auto-raise flag and Focus Prevention level to "Off" in CompizConfig

0

I was seeing this issue on Unity under Ubuntu 14.04 and solved it today. This fix should apply to any version of Unity I think.

In CompizConfig Settings Manager (ccsm), go to Window Management and make sure the Put module is enabled. Clearly Put is responsible for the initial placement of windows.

Hope this helps someone else out. This was driving me crazy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.