I am using an external script (http://trac.ffmpeg.org/wiki/Concatenate#extscript) to concatenate multiple MP4 files. This script lets you do a command like this:

./mmcat input1 input2 input3 ... output

to concatenate multiple files.

I am using this command right now:

./mmcat.sh video1.mp4 video2.mp4 video3.mp4 "output.mp4"

After getting an "Operation not permitted" error, I logged the results, which are listed below:

In log.v.3 and log.v.2:

[yuv4mpegpipe @ 00000190aa080a20] ERROR: Codec not supported.

Could not write header for output file #0 (incorrect codec parameters ?): Invalid data found when processing input

In log.a.2: Temp/mcs_a2.lnk: Permission denied

In log.a.3: ...AppData/Local/Temp/mcs_a3.lnk': Output file #0 does not contain any stream

I would appreciate any help, as I'm very new to using ffmpeg and just a beginner at video encoding etc., in general.

  • I've never tried that script, but you may be able to just use the concat demuxer instead as shown in that same link. – llogan Feb 5 '16 at 20:37

Had the same problem, then found this post in its mailing list after weeks of debugging.

Worked for me after removing every occurrence of -vcodec $PARAM [1] in mmcat script.

[1]: $PARAM is not literal, it's whatever value used for ffmpeg's -vcodec option in the script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.