20

I just bought the Sony MDR-XB950BT and it works amazingly with my iPhone, but when I connect it to my laptop the sound is like an old radio! I searched for solutions but nothing fixed it!

The headphone appears in the playback devices as headset and a stereo headphone, and the headset is only one that have the sound when it is default. the other one is showing there is sound but actually there is nothing.

I checked the services and it is working.

I also found the uncheck the Handsfree Telephony solution but when apply the change the headset disappears and the Stereo headphone doesn't and stay the same with no sound.

10 Answers 10

15

After much frustration, googling and facepalming without getting any wiser, the following "WTH-I'll-just-try-this" fix worked for me:

  • go to bluetooth settings.
  • your bluetooth headset should show "connected mucic, voice".
  • now, go to control panel -> sound.
  • on the "playback" tab, your headset should be shown as a hands-free part, and a headphones part. Now, disable the hands-free part, and go to the "recording" tab and do the same.
  • problem solved, at least for me. I tested disconnecting my BT headset and connecting it again to see if Windows defaults it back to the hands-free profile, and whaddyaknow, it didn't. I can finally enjoy good sound quality in my JBL E55BT headset without any more hassle.
3
  • Turning off the recording aspect of the bluetooth device is a very smart approach here. This also worked for me. I was using Bose wireless headphones, but the key to this solution was the same: disable the hands free aspect in the recording tab (I disabled it in the playback as well). At the end of this, I did have to disconnect and reconnect the headphones in order to have the updated correct Stereo connection created. Thanks! – Travis J May 18 '20 at 17:48
  • unbelievable, it worked, it's that simple! – Chagai Friedlander Feb 28 at 8:38
  • Worked, thank you so much! Was rapidly losing the will to live... – Al Sweetman May 24 at 9:26
5

I had this exact same problem with the Sony MDR-XB950BT, but the previous solutions listed here didn't work for me.

Here's what did work for me, in case it helps anyone else who finds this question in the future:

  • Open Device Manager

  • Expand 'Bluetooth'

  • Disable the MDR-XB960BT Avrcp Transport Adapter

  • Restart Computer

Screenshot of Device Manager

Also of note: When the Sound Properties control panel is open, I don't get audio to the headphones, however, it starts working again once Sound Properties is closed. When the Sound Properties control panel is open, it is playing the headset's microphone input to the headset rather than playing the computer's audio output to it for some bizarre reason.

1
  • 1
    This worked for me with the JBL E45BT. Only difference was my path to get to the drivers was slightly different. Device Manager >>"Sounds, video and game controllers" >> "JBL E45BT Hands-Free" – FredFury Jun 8 '19 at 19:02
3

I just ran into a similar situation, only hands-free, no stereo. Device manager indicated something wrong with Microsoft Bluetooth A2dp source. The solution is to Run the System File Checker tool. Got the idea from here (WH-1000XM3, Windows 10 pro 1903)

2
  • That really helped. I noticed that Microsoft A2DP Source device showed problems in "Device Manager". It showed some error about corrupted files. The above instructions to scan and restore system files did the trick. The A2DP device disappeared from the list but everything started to work. Reinstalling wireless and bluetooth drivers alone didn't help. – akostadinov Aug 27 '19 at 11:37
  • +1! Had the same problem. My headphones (same model) were only recognized as Hands-Free-device. Tried to un- and re-pair them countless times, un- and reinstalled Bluetooth drivers, disabled Hands-Free service in Config Panel->Devices and printers ... no luck. Then I ran the System Checker tool and boom ... 2 devices (Stereo and Hands-free). Thank you! – flecki89 Nov 26 '20 at 18:21
2

Try reinstalling the Bluetooth speaker drivers by:

  1. Opening device manager, WIN+R then type devmgmt.msc and then press enter
  2. Expand the list item Bluetooth
  3. Right click on the problematic Bluetooth peripheral
  4. Select Update driver
  5. In the window that appears, select Browse my computer for driver software
  6. Click on Let me pick from a list of device drivers on my computer
  7. Select Next and once complete, perform a reboot

This should fix most problems with Bluetooth devices, including speakers or headphones

1

Same issue here and I've spent two days digging. In the end I've enabled the AVCTP service (it was disabled manually by me earlier).

1
  • Please expand your answer to include the details of how you determined the cause of the issue. – Xeнεi Ξэnвϵς Jan 2 at 9:52
0

Ok, I fixed it!

Anju Thekkethil on Microsoft community gave me methods that might solve my problem and method #2 did it!

I just uninstalled the bluetooth drivers from device manager and then restarted my laptop and it was fixed!

here is his awnser: https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/poor-sound-quality-on-bluetooth-headphones/f3486fe3-ec73-4b04-bec5-db20e6e5a794?tm=1454758592416

1
  • Did it ever break again after you got it fixed, or did it continue working? – Neil Apr 25 '20 at 23:25
0

I had to go to 'Devices and Printers' in Control Panel. Then there under 'Devices' I found the bluetooth speaker, and pressed right button on the bluetooth speaker and pressed 'Remove Device'. Afterwards connected through Bluetooth again and it had to set it up as a new device and it made it work perfectly.

And before I tried uninstalling/re-installing all sorts of stuff, but it didn't help at all.

Hope this helps

0
0

My problem showed the stereo headset and hands free but only the hands free would be enabled no matter what I did. After several other methods I was able to fix it by removing the device and adding/pairing it again.

0

Had this issue today after a windows update. Non of my bluetooth headsets (Nuraphones/Jaybird Tarah Pro) would only connect hands-free. No Stereo. This reflected in the sound "playback" setting.

After running through everything in this thread, I ended up following half of @Chao solution.

Windows 10:

  1. Go to Device Manager
  2. Under "Sound, video and game controllers" I had an error on "Microsoft Bluetooth A2dp source"
  3. Disable it, then enable it
  4. Disconnect and remove headphones from Bluetooth
  5. Reconnect headphones

Stereo option then appeared in the Sound "playback" tab.

Windows 10 Sound "Playback tab" Window

0
  1. Right-click the sound button and press "open sound settings"

  2. press the "manage sound devices" button. on the input, section click the hands-free headphone and click disable

  3. check your sound to make sure it is working

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.