1

I'm logging in through Remote Desktop from Windows 10 to a Windows Server 2008 R2 machine. On the Remote Desktop Connection dialog on the client machine I have specified a user name and have allowed saved credentials. In the past, this has allowed me to always connect without typing the password on each connection.

Now, when I'm disconnecting from an existing session and then trying to reconnect I get the "choose user" screen (showing the user pictures of several local users on the remote machine), forcing me to (re-)select the user and re-type the password. This doesn't happen when there is no existing session for the user I'm logging in as, in this case I'm automatically logged in.

I have tried:

  • Deny the other users RDP rights: they still show on the "choose user" screen even though they can't log in
  • Hide users from the login screen through the dontdisplaylastusername registry key: Users aren't shown, but I still have to type user name and password when a session for the user I'm trying to connect as already exists

How can I always log in without typing a password (connecting to an existing session if there is one)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.