22

I visited a foreign website and I accidentally clicked "Never translate this site". I want to revert this back to the default behavior of Chrome always asking me what to do. How do I do that?

Thanks in advance.

0

4 Answers 4

24

Corrected my answer as pointed out.

First Method

  • Go to the webpage you want translated
  • Bring up context menu via right-click
  • Click translate to "your default language"

Second Method

  • Go to C:\Users\%USERNAME%\AppData\Local\Google\Chrome\User Data\Default
  • Open Preferences with a text editor
  • Search translate_site_blacklist
  • Find and delete url of the page you want translated "translate_site_blacklist":["page you want translated","some other url","one another"],
  • After edits it should look exactly like this : "translate_site_blacklist":[""]

These will translate the page and / or reset your settings for that page.

12
  • 2
    That's not what the OP intended, your answer indicates you can change the languages which are suggested or disable this feature. There's no option to undo a "never translate" choice.
    – Terry
    Commented Feb 8, 2016 at 14:17
  • thanks for pointing out my mistake. it was a misunderstanding on my side. i corrected the answer. Commented Feb 8, 2016 at 14:27
  • I'm not sure who downvoted, some people lack the interest in positive feedback. In anycase, that's also what I was thinking so +1 from me.
    – Terry
    Commented Feb 8, 2016 at 14:33
  • Thanks for the replies, but it didn't work. I edited the file by removing every value after the colon, so the end result is "translate_site_blacklist":,"SYNTAX", and then I fired up Chrome. It said that the preference file is corrupted and can't be recovered, and it restores itself back to its default settings - and logs me out. To get my settings and data back, I have to log-in - and that's stage I guess the preferences file reverts itself back to its pre-edit state. When I enter that website, it is shown in its original language with no popup offering me translation.
    – voronoi
    Commented Feb 8, 2016 at 19:16
  • you just have to delete "page you want translated", part. not more than that. (including " and , ) Commented Feb 8, 2016 at 21:04
22
  1. Open Chrome on the device that has the problem (smartphone, computer, tablet)
  2. Enter this address: chrome://about
  3. Click chrome://translate-internals
  4. In Untranslated sites delete the site that does not offer the translation of pages

Note: Must be done for each device that presented the problem (smartphone, computer, tablet).

1
  • The accepted answer (right click -> translate page) is the easiest way to answer the original question, but this page is awesome and I wish I'd known about it sooner.
    – Coderer
    Commented Apr 2, 2020 at 13:08
2

new chrome is a bit different, these work:

Open Chrome on the device that has the problem (smartphone, computer, tablet)

Enter this address: chrome://about

Click chrome://translate-internals

but now you just click the X next to the site you want to revert to (translate, never translate, always translate)

0

I've had same problem. I've made a mistake and for a Chinese side selected never translate; even though, now I fixed it, but I really don't know which one of my works made it.

  1. I selected 'Settings', in 'Advanced Settings' I chose 'Language' and then removed all languages, then reselected 'English' and some other languages.
  2. I've opened a Chinese site and selected (•••) above of the page and selected (translate ...) Option.

Since that, on Chinese sites, it always asks for translate!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .