2

I had both Ubuntu and Windows installed in dual-boot config. Windows 10 was on my SSD and Ubuntu 14.04 on the HDD. One day, the HDD crashed and Ubuntu was gone, not a big deal because I got a new HDD. But in the UEFI of my Asus z-97 motherboard, signs of Ubuntu were still there. Like in the boot menu I could still choose Ubuntu, but that did not make anything because the HDD was gone.

I wanted to remove all rests of Ubuntu and tried to use EasyBCD. I used the repair boot file option in the BCD management option. After that I tried to reboot and, surprise, I can't do anything. It just sticks with the Asus logo with the text "press f2 or del to enter bios" which I obviously tried without working. I cannot enter the UEFI firmware, and it does not boot on the only OS on my computer (Windows 10).

What should I do?

  • Might not be helpful but you probably shouldn't have used easybcd to deal with it in the first place. It's simply an entry in the NVRAM and you can use efibootmgr (in an Ubuntu live medium) to remove it. I have no idea what easybcd had done, maybe reinstalling the windows uefi bootloader with bcdboot.exe can help: technet.microsoft.com/en-us/library/dd744347%28v=ws.10%29.aspx – Tom Yan Feb 8 '16 at 14:44
  • Thanks for your answer. Yeah i immediately regretted this. Problem is that i can't enter the bios and windows won't boot either. It just the logo asus and nothing can be done. Is there a way to reset manually the motherboard? – neddhelp Feb 8 '16 at 14:56
  • Maybe you can try remove the CMOS battery for a while then put it back and see. – Tom Yan Feb 8 '16 at 15:00
  • Unfortunately it did not change the situation – neddhelp Feb 8 '16 at 15:14
  • Have you disconnect the computer from a/c power completely before did that? You can also check out the jumper to clear rtc ram (1.2.7, 1) and the q-code led (1.2.8, 6) to see if any of them help: dlcdnet.asus.com/pub/ASUS/mb/LGA1150/Z97-PRO/E9062_Z97-PRO.pdf – Tom Yan Feb 8 '16 at 15:20
0

This is not a good answer but let me try to explian what happened so we can at least get to the right path to solve it.

First: You do not have an BIOS. You have EFI. EFI and BIOS are different firmwares. A firmware loaded with the BIOS program behaves quite differently from the firmware loaded with an EFI program. EFI stores innformation in NVRAM, which included the bootloaders.

That means that the initial bootloader for Ubuntu was not on the failed HDD. It was safely in NVRAM and it stayed there when the disk crashed. This is why you still see it after the disk has been replaced.

The way to remove it would be to go to your EFI shell and remove it, or load an OS with tools (e.g. Ubunto on a USB pendrive) and edit/remove the EFO settings.

Note that removing the battery (which would clear BIOS settings) does not work here since you do not have the clasic BIOS and battery backed storage. Instead you have UEFI and NVRAM.

Sadly that is as far as I can really help. I do not know what Easybcd's repair boot file option does, and thus no idea how to undo it. Which makes this rather lacking as an answer, but hopefully it will still set people on the right path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.