0

Sometimes, I highlight text in an MS Word document and wish to add a comment about it to send to a co-author. Following this official documentation about keyboard shortcuts (in the “Review documents” section), I then press Alt+Ctrl+M as the keyboard shortcut to insert a comment. I usually use the modifier keys on the right side of the keyboard because they're close to the M and I can easily cover all three with the hand that didn't just use the mouse to select that text. To within human perception time, I often press both modifier keys simultaneously, before the M (so I don't type an m).

However, about half the time, instead of inserting a comment, the highlighted text is deleted and replaced with a lowercase mu character (µ). After years of being unable to figure out the pattern, I have finally found that on the right side of the keyboard, if I press Alt+Ctrl+M (with the Alt key going down first) I get the µ, and if I press Ctrl+Alt+M (with the Ctrl key going down first), I get the comment. If I use the modifier keys on the left side of the keyboard, the order doesn't matter and I get the comment either way.

When I right click on the Ribbon and choose "Customize the Ribbon"→"Keyboard Shortcuts," I can see that the shortcut to insert a comment is listed as Alt+Ctrl+M:

enter image description here

Although the modifiers are listed in the wrong order, this matches the Office documentation.

When I go to the Insert→Symbol→More Symbols dialog, it says the shortcut key assigned to the mu character is Alt+X, nothing like Alt+Ctrl+M:

enter image description here

EDIT (thanks to Jonno for these questions): My Windows keyboard layout is US English. The Ctrl key can be omitted in the right-side-Alt+M combination and I still get the µ character. However, right-side-Alt+M (with or without Ctrl) does NOT produce the µ character in other Windows applications such as Notepad, WordPad, Firefox, or Chrome. Therefore, I am doubting the "system keyboard mapping" theory (thanks Jonno!) that previously seemed promising.

There may have been some time in the past where I needed to type a lot of µ characters, but that time is not the present, and it's annoying to accidentally delete some portion of a document and replace it with an unexpected character, especially after most proofreading checks have taken place and shortly before that document is formally submitted.

Why am I getting µ characters for Alt+Ctrl+M or Alt+M (but only with right side modifiers, and not for Ctrl+Alt+M), and how do I get rid of this behavior?

  • (1) Look again.  It’s not saying that the shortcut for μ is Alt+X; it’s saying that it is “03BC, Alt+X” — i.e., type “03BC” normally, and then press Alt+X (the shortcut key for converting a two- to five-digit hex number to its corresponding Unicode character; e.g., “40, Alt+X” turns into “@”).  … (Cont’d) – G-Man Apr 7 '17 at 6:43
  • (Cont’d) … (2) You say, “There may have been some time in the past where I needed to type a lot of µ characters, …” Is it possible that you defined this Alt+M shortcut and forgot about it? Try this: (a) exit Word, (b) rename your Normal.dotm to a backup, (c) restart Word, and (d) see whether you still have the problem. (3) If you delete the selected text, can’t you get it back with Ctrl+Z? – G-Man Apr 7 '17 at 6:44
1

AltGr+M, according to various online sources (I can't test it as my keyboard hasn't got AltGr) is the keyboard shortcut, with a lot of keyboard layouts, for the µ symbol (see here).

enter image description here

In terms of disabling this, one solution from here is to add the following registry key, to treat AltGr as the standard Alt:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,38,00,38,e0,00,00,00,00

Alternately there is software called “SharpKeys” that will set this for you.

One other option is to use the Microsoft Keyboard Layout Creator to change your keyboard mappings and remove this particular shortcut. Some information on the usage of this can be found here.

0

Heads up: This is still just a partial answer.

In the “Insert Symbol” dialogue, pressing a keyboard shortcut of interest takes you to the character that would be inserted had you pressed that in the document. (Here, it works even when putting the Ctrl key down first.) This is a helpful tip for tracking down the rogue shortcut.

As it turns out, there is another character called the "Micro Sign" which is visually identical to the Greek Small Letter Mu. This key has a baked-in assigned shortcut key of Alt+Ctrl+M as well, but if you click on “Shortcut Key…”, it doesn't show up in the (empty) list of keyboard shortcuts:

enter image description here

Assigning an alternative shortcut causes the new shortcut to appear in place of Alt+Ctrl+M next to "Shortcut key" and in the list of "Current keys" as expected.  Unfortunately, it does not displace the Alt+Ctrl+M "functionality" of inserting µ, and if you remove the new shortcut the Alt+Ctrl+M shortcut key reappears next to "Shortcut key" but not in the list of Current keys (i.e., it's a return to the state shown above).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.