0

How does one get a working setup to join a WebRTC session (e.g. https://opentokrtc.com or for testing https://test.webrtc.org) with a Raspberry Pi 2, the official camera module (and a USB soundcard)?

How I tried it in several attempts so far:

  • Boot Raspbian from microSD (also tried other distros)
  • update all available packages
  • set GPU/RAM split to somewhere around 192 - 256 MB for GPU
  • install iceweasel
  • visit one of the above sites, nothing happens (empty screen or black rectangle appears, no popups asking about sharing webcam/microphone)
  • install all available v4l2 packages
  • reboot
  • run iceweasel again
  • it asks now for sharing webcam, microphone when visiting sites mentioned above, also shows the USB sound card (which works fine for playing audio)
  • camera video pops up for about two seconds in random place on screen
  • video vanishes
  • same behaviour as before, failing to stream neither audio nor video
  • running e.g. raspistill to capture an image from the camera works just fine
  • installing chromium gives similar results, does also not work

After almost one full day of trying I didn't get anywhere. My goal was to use the Raspberry Pi as a video conferencing client which I could just leave running in our office, for people in my team doing home office. I read a few accounts of people managing WebRTC in their browsers on the Raspberry Pi, yet I failed.

Are there any known ways to get a Raspberry Pi to successfully join a video conference?

2 Answers 2

1

Try UV4L with the Jitsi Meet plugin. It allows bidirectional audio&video on conference rooms over the web. You can specify room and username through the web interface. You do not necessarily need a browser on the Rpi2.

3
  • This is unfortunately not working. The interface greys out, as it should, after pressing start. But in the Jitsi room which I joined from another device is not joined, the Raspberry Pi does no show up.
    – Riley
    Feb 10, 2016 at 20:56
  • follow the jitsi tutorial step by step you are probably missing something important. i have just tried, works perfectly.
    – smerdon
    Feb 10, 2016 at 23:29
  • Beginning to suspect it might be the camera I bought. With uv4l-uvc and a USB-cam it works. Weird though that raspistill and raspivid work flawlessly.
    – Riley
    Feb 15, 2016 at 14:27
0

I see this is an old post but still, I have tried many things with this, the best and simplest solution for streaming from PiCamera in my opinion is:

  1. Loading the uvl4 camera module driver "sudo modprobe bcm2835-v4l2", MY
  2. Use Iceweasel or Firefox for WebRTC

If it`s not working, try to restart your Pi.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .