2

The "install vmware tools" is grayed out in windows 8.1 guest, Linux host vmware workstation 12.

I tried the suggestion in this link with no success

I have tried starting windows with cd/dvd not connected (this results in an empty cd/dvd drive showing under my devices in the windows 8.1 guest but "install vmware tools" still grayed out)

I have tried starting the windows guest without the cd/dvd and then going to vm / removable devices / connect

I have tried ejecting the cd/dvd from within windows (the iso used to install is in the directory by default, there is no option I can see to mount a empty virtual cd/dvd) but "install vmware tools" is still grayed out

I have tried re-installing windows to see if that would bring up the option

How can i get vmware tools install working?

Or better yet, how can i skip the problematic interface and download vmware tools for windows 8.1 guest from within windows and then install it?

see pic

8
  • Can you provide a link to a screenshot that shows your CD/DVD drive is successfully mounted? As well as show us a df or mount command output to see what devices are mounted via the host? – DrZoo Feb 8 '16 at 20:07
  • hello, i've updated my post to show a link to pic showing visual and terminal data showing drive is mounted. Linked because embedded pics are not enabled for my account. – jtlindsey Feb 8 '16 at 20:22
  • Also, running the df and mount command on the host does not show virtual devices mounted in guest unless i map those drives – jtlindsey Feb 8 '16 at 21:01
  • Try this suggestion by shaunm2 – DrZoo Feb 9 '16 at 1:28
  • @DrZoo thanks for the tip. I tried it as regular user and root with reboots and workstation restarts. I also tried toggling proxy settings while guest was running with no luck. – jtlindsey Feb 9 '16 at 4:20
1

Upon moving to the chat a solution was found. I mentioned manually downloading the .iso and try installing it like that. It ended up doing the trick.

Steps performed by jtlindsey - I manually downloaded the .iso on my host machine, went into my windows guest machine settings and set cd/dvd to the path of my .iso, booted windows and launched the vmware tools and installed like normal.

It also appears that the VMWare Tools .iso Archive is tricky to find via Google search so below is a link for those who may come across this question in the future.

VMWare Tools Archive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.