0

How do I enable hyperthreading on CentOS 6? I checked the flags field in /proc/cpuinfo and ht is in the flags section. Below is my processor information.

~$ lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                20
On-line CPU(s) list:   0-19
Thread(s) per core:    1
Core(s) per socket:    10
Socket(s):             2
NUMA node(s):          2
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 63
Stepping:              2
CPU MHz:               1200.000
BogoMIPS:              4589.06
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              25600K
NUMA node0 CPU(s):     0-9
NUMA node1 CPU(s):     10-19
  • Did you check the question and answers here? – JakeGould Feb 9 '16 at 18:16
  • Yes, I did look at that. There are plenty of answers of how to check if it is already enabled or if it is possible to enable, but I didn't see any answers that describe how to actually enable it. – irritable_phd_syndrom Feb 9 '16 at 18:19
  • Well, my understanding is threading would be controlled by the BIOS of the system and not be configurable in the OS past that hardware setting. But this post shows how to disable hyper threading via a Kernel tweak; maybe this can give you clues on how to enable it by doing similar things in reverse? – JakeGould Feb 9 '16 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.