0

I used windows diskpart to clean and format a 64mb compact flash card I use to backup work on industrial machines. Prior to this diskpart format, I was able to boot to this compact flash card by placing 2 files on the drive and powering on the machine (windows embedded). Now, I can put the same files on the drive, but the disk will no longer boot. What could diskpart have done to this disk to make it unbootable? The diskpart commands I ran were:

  • select disk x
  • select volume x
  • clean all
  • create partition primary
  • format fs=fat label=”mydisk”
  • You sure there were no other hidden boot files? Have you tried "fat32" or "ntfs" instead of "fat"? AFAIK the FAT32 and NTFS created by Windows has the necessary boot code for bootmgr. Last but not least, you didn't seem to have made the partition "active". – Tom Yan Feb 10 '16 at 18:16
  • I am certain there were no other files. I've only done fat because known good cards are fat too. I am suspecting when cleaned, the diskpart app creates an mbr or some other low level boot sector item in some place other than where the disk previously had it--where my device is not looking causing the fail. But I do not know how to view that level. – Flotsam N. Jetsam Feb 10 '16 at 22:26
  • AFAIK when you recreate a partition, diskpart will write the necessary boot code to MBR as well. Basically the code look for the active partition and execute the boot code on its filesystem. – Tom Yan Feb 10 '16 at 23:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.