My Macbook Pro HD is divided in 3 partitions of equal size. The first one has Snow Leopard installed on it, the second one has Windows 7 on it, and the third one is used to store backups (Clonezilla disk images) of the first two partitions.

Note: I did not use bootcamp. I just installed Windows from the setup dvd and installed the bootcamp drivers afterwards.

This worked very well until I restored my Mac disk image. Snow Leopard runs fine, but when I can't boot Windows anymore. If I press the ALT key during startup the system only shows the icon for the Mac partition.

Disk utility shows the Windows partition as "disk0s3" and in gray. The "verify disk" button outputs "Invalid B-tree node size."

Any ideas on how to fix this?


I think bootcamp is doing more than just partitioning, in the background it makes the Mac OS aware of the Windows - so this doesn't happen.

I suspect you may have to pay for software to get out of this predicament unless you're willing to wipe the partition and re-install, you could try downloading iPartition and see if it can see the Windows volume. If it can you'll need to cough up to get the full product. There is open source re-partitioning software gparted but it's user hostile.

I would suggest DiskWarrior for most disk related shennanigans, but its about $100 and may not help with the FAT/NTFS partition - I've never tried it on this.

Use Bootcamp next time!

  • You are correct. I recently reinstalled Windows using the official bootcamp procedure and I haven't experienced any problems when restoring my disk images. – StackedCrooked Feb 17 '10 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.