10

How to disable/enable WIFI when Ethernet connection is available in Windows 10. My Ethernet connection is faster than my Wifi, but Windows 10 keeps routing via Wifi when I connect. Is there any way to disable Wifi based when Ethernet is connected?

This question was posted for Windows 7, but for Windows 8 or 10 there's no similar procedures.

1
  • problem also applies to Windows 11
    – Roland
    Feb 17, 2023 at 11:21

3 Answers 3

7

Steps:

  1. Go to View Network Connections or Control Panel\ All Control Panel Items\ Network and Sharing Center > click on 'Change adapter settings' then use the alt button to show menus and select Advanced Settings... Ethernet's Advanced Settings
  2. Under Connections section, select Ethernet, and use the arrows to the right to move Ethernet above WiFi.
  3. Click OK.

Windows will now prefer the Ethernet over the WiFi for connecting to the internet. This should apply for Windows 8, 8.1, and 10.

7
  • It worked! Thank you. To check you can connect and disconnect the ethernet cable and see wifi connection connect and disconnect. You can also check it using route print in command prompt and check the fist IP on IPv4 Route Table. Mar 9, 2016 at 3:03
  • 7
    When I choose "Advanced Settings..." on Windows 10 it just gives me "Network Providers" which are "Microsoft Remote Desktop Session Host Service", "Microsoft Windows Network", "Web Client Network". None of these options look like Wifi or Ethernet. I only have a "Provider order" tab.
    – bobpaul
    Nov 10, 2017 at 23:48
  • 5
    @bobpaul According to a 2015 Microsoft Networking Blog article "Adjusting the Network Protocol Bindings in Windows 10", the feature was removed from the UI because binding order is no longer used to prioritize routing. The article gives new instructions for prioritizing routing. Basically you look at the interface priority with netstat and change it with Set-NetIPInterface in PowerShell.
    – MetaEd
    Feb 20, 2019 at 20:45
  • @MetaEd, your link was since deleted, so the newer method might be obsolete by now too. If not, would you mind making a new answer detailing it?
    – LWC
    Oct 1, 2020 at 16:42
  • 4
    I fixed this by running the powershell command "Get-NetIPInterface" to see the InterfaceMetric for my WiFi and Ethernet adaptors and then "Get-NetAdapter | where-object {$_.Name -eq "Ethernet"} | Set-NetIPInterface -InterfaceMetric 3" to give this a high (low number) priority and a similar command with "Wifi" with a high number (I picked 120 to be higher than anything else) Oct 8, 2020 at 8:56
5

Good guide here for Windows 10: How to change the priority order of network adapters on Windows 10

  1. Open Settings.
  2. Click on Network & Internet
  3. Click on Status.
  4. Click the Change Adapter options item.
  5. Right-click the network adapter you want to prioritize, and select Properties

Adapter Properties Image

  1. Select the Internet Protocol Version 4 (TCP/IPv4) item
  2. Click the Properties button.
  3. In the "General" tab, click the Advanced button
  4. Clear the Automatic metric option
  5. In the "Interface metric" field assign a priority value for the adapter - Lower is prioritized, for me, everything was set to 35 (Wifi and Ethernet), so I changed Ethernet to 15

Changing the Interface metric image

Typing Get-NetIPInterface into Powershell will give you a list of the InterfaceMetric numbers if you need them, mine ranged from 25 to 75.

1
  • I have windows 11 and cannot find ADVANCED :-(
    – Roland
    Feb 17, 2023 at 10:51
2

This problem is of course not limited to Windows 10. I have Windows 11, and the above answers did not work for me. But the powershell command is also a solution.

Get-NetIpInterface

(not case sensitive) will show the metrics: output of command Get-NetIpInterface

In my case, index 44 appears twice, and in one instance, the metric is empty. To set a metric, you can type this command in a PowerShell As Administrator shell:

set-netipinterface -interfacemetric 15 -interfaceindex 44

Note that I set a metric of 15, i.e. lower than the 35 of the wifi, because a lower metric has a higher priority.

Rerun the Get-xxx command to verify the new setting.

Run this command to verify that the system has selected the Ethernet connection over the wifi:

ipconfig

The output will show that wifi is "disconnected", and that the Ethernet adapter has an IP address assigned to it.

1
  • 1
    Thanks for the Windows 11 awnser! Feb 19, 2023 at 4:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .