2

I posted this on serverfault, but they have voted I move this question to this forum and I am unable to delete the question.

Here is my scenario:

I have two computers, one a windows 8.1 machine that hosts the HP LaserJet 4100 printer. It has a static IP. It has a LPT port, which is used by the printer. I have printed pages on the printer successfully from that machine. The other machine is a windows 10 machine. I have been trying to share the printer on the network via the windows 8.1 machine and add it to the windows 10 machine. I have followed several online tutorials that give me instructions on how to do this. Both computers are connected to the building wired network.

I have followed multiple tutorials online to share the printer with the network.

I have marked the printer as a shared device in the printer preferences.

I disabled the public folder sharing and media, but everything else was activated in the advanced sharing settings.

After setting up the printer on the network, I go to the Windows 10 machine and click "Add new printer". As seen from the links above, I have enabled printer and file sharing and disabled usernames and passwords. Both machines are in the default workgroup "WORKGROUP". I have attempted to add the printer by typing in the IP address when selecting the option to add the printer via the IP and I have also tried adding the printer by typing in "\computername\printername', (they're really two backslashes behind of the computer name but I can't show that here because they're escape characters) however when I do this for the first time, the windows 10 machine asks for a username and password. The Windows 8.1 machine has no password, just a username. This is odd, because I have disabled the ability to use usernames and passwords when adding this printer. I have put in the domainname\username and a blank password, since there is no password on the machine, and I have received an error that says "Access Denied". I have looked into the permissions given to the printer when looking at the printer preferences and when All Users or Everyone is selected, the permissions to print documents and manage the queue have been given to all users.

I have tried to add the printer when it was configured to manage the queue on the client machine and when it was configured to manage the queue on the host computer. Neither configuration has worked.

I've continued to try this same process over and over again, even on another machine on the network, and yet I am still unable to add the printer. Help is greatly appreciated!

Also, would creating a new workgroup and assigning both computers to that workgroup help? Does printer sharing not work very well when the default workgroup is used?

1

as long as both computers are in the same workgroup ur good. the 8.1 must have printers shared. EVERYONE should have full access. I don't remember doing anything with public access so I am not sure how that is affecting u.

I believe the UN & PW it is looking for is the one for your machine, but if 8.1 doesn't know of it, it is no use. I keep having these issues with sharing folders between my computer and by some stroke of luck I finally get the formula. U could also try using HOMEGROUPS.

If the printer is properly shared on the 8.1 then when W10 searches for it, it should find it. So I would go back to the 8.1 to verify it is properly shared.

  • Right on. Homegroups worked perfectly. Funnily enough, when I created a Homegroup on the host computer, I could add the printer to other computers without that computer joining the Homegroup. That could be because of the Homegroup, or because the computers had been restarted earlier that morning. However, none of the tutorials I read called for a restart, but it sounds logical. (Cue quote from IT Crowd) – TheRedCameron Feb 11 '16 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.