32

I am having the issue that Win+←/→ does not snap the windows to the side of my monitor, this is similar to

The Solutions on all these places explain how to (re)enable Aero Snap, but Aero Snap is working for me, I can snap the windows with the mouse (for example), just not with the keyboard. Other keyboard shortcuts (all) work fine, e.g. I can shift monitors using (ctrl+Win+←/→), so it is a very, very specific shortcut failure.

Of course, I have also tried disabling and re-enabling 'SNAP' in “SETTINGS > SYSTEM > MULTITASKING, that does not fix the keys-specific issue. I have tried using the on-screen keyboard and the problem persists.

One possible red-herring is that I recently disabled 'narrator', (Capslock+Esc), as described here, that is the only system modification I can remember making in the last week.

The keys-shortcut problem appeared completely arbitrarily, without a computer restart or keyboard reinstall or other modifications.

9
  • 6
    haha, restarting the computer solved the problem - service desk 101. Commented Feb 10, 2016 at 9:57
  • You should consider adding your own answer to your question. Commented Feb 10, 2016 at 11:48
  • 1
    I keep getting this. Very annoying none of the solutions apply / work for me. Very very annoying. All other combos I use work fine. Keys on their own work fine Just win + arrows problematic wonder if there is an easy way to setup alternative key combos? Commented Mar 16, 2016 at 16:24
  • 1
    ConEmu caused it for me, see this answer: superuser.com/a/1091991/132859
    – dvdgsng
    Commented Jul 26, 2016 at 9:26
  • 1
    thanks @dvdgsng! restarting explorer was no help, but restarting conemu did the trick. Commented May 8, 2017 at 23:04

5 Answers 5

31

You have to enable Snap from Settings, System -> Multitasking.

enter image description here

3
  • 6
    Oh- damn it. This was the answer I was looking for but looks like I can not have "windows+arrow key" keyboard shortcut enabled, and have the snapping feature disabled. It is really annoying dragging windows across monitors and have my mouse stuck on the side of one of the screens.
    – Nican
    Commented Jun 23, 2018 at 21:13
  • I had this setting ON and it didn't work. After I set it to Off and then back to ON it started working. Commented Nov 30, 2021 at 19:58
  • Same for Windows 7: disabling snapping windows also disables those Win+Arrow shortcuts. Find "Ease of Access Center > Make the mouse easier to use".
    – AmigoJack
    Commented Feb 2, 2023 at 21:48
24

If you want to avoid a restart, you can restart the explorer.exe process.

Step by step

  1. Open Task Manager (Ctrl+Shift+Esc)
  2. Go to the Details tab
  3. Kill the explorer.exe process.

Kill explorer process

  1. In the Task Manager, click File --> Run new task

enter image description here

  1. Type in explorer

enter image description here

3
  • cool, i can't try it obviously, but I guess this might troublehshoot other problems as well. Commented Sep 8, 2016 at 19:57
  • 1
    There are many annoying Windows UI problems that can be fixed by restarting explorer.exe . It doesn't lose anything except currently open windows. And perhaps if you're renaming, moving, or copying a file while you're doing it. Commented Oct 21, 2016 at 20:02
  • This worked for me. You can also save a step in Windows 11, just right-click on "Windows Explorer" and click "Restart". That does the trick, and you don't have to run a new task.
    – CigarDoug
    Commented Jun 27 at 13:16
8

I tried every one of the suggested fixes on this solution and on the other page links at the top.

None of them seemed to work. I rarely use the Win key outside of "Windows Snap" shortcut, so I tested a few other Win+key hotkeys (e.g. Win+D) - didn't work either. So what I thought was a "Win+Left/Right Arrow" (aka Win Snap) issue - wasn't the actual problem...

Solution (Fixed Everything) :: DISABLED "GAMER MODE" Toggle Key on Mechanical Keyboard. (Logitech G910). I never use Gamer Mode Toggle and didn't even realize it was Enabled.

Hope that helps anyone out there w/ Gamer Mode Toggle Keys cause this has been bugging me for a while.

0
4

The answer to the original question also lies in Ease of Access / Mouse settings -- see it at this link (posted by zaraTzara):

  1. Go to: Control Panel >> All Control Panel Items >> Ease of Access Center >> Make the mouse easier to use
  2. Under ‘Make it easier to manage windows’: Uncheck ‘Prevent windows from being automatically arranged when moved to the edge of the screen’.
3

This happened to me on Windows 10, stopped right after I had just been using it. Explorer has some bug evidently which stop listening for the shortcut key. The Windows key still works, but the key sequence Windows + Arrow is ignored by the OS.

Enabling or disabling Snap via Windows+I Multitasking had no effect - the feature was not the problem.

Command Prompt

@powershell kill -name explorer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .