I Have found these steps to add SSL self attested certificate in chrome for sites having invalid SSL certificate. I have have added exactly as mentioned but still when I reopen the site I have the same red lock in the link bar. Here are the steps.

  1. On the page with the untrusted certificate (https:// is crossed out in red), click the lock > Certificate Information.
  2. Click the Details tab > Export. Choose PKCS #7, single certificate as the file format.
  3. Then follow my original instructions to get to the Manage Certificates page. Click the Authorities tab > Import and choose the file to which you exported the certificate, and make sure to choose PKCS #7, single certificate as the file type.

    Manage Certificates page:

    • Open up Chrome Settings > Show advanced settings > HTTPS/SSL > Manage Certificates.
    • Click the Authorities tab and scroll down to find your certificate under the Organization Name that you gave to the certificate.
    • Select it, click Edit, check all the boxes and click OK. You may have to restart Chrome.
  4. If prompted certification store, choose Trusted Root Certificate Authorities
  5. Check all boxes and click OK. Restart Chrome.

Although, I just added an exception in Firefox and it worked well.

Could you tell me any other solution to get the site working, as I want to store my password for the site and because of that I am not able to do it.


SSL certificate is not suppose to be self-signed. Self signed certificates are considered CA certificate which shouldn't be used for SSL and browser will warn any such usage. I suggest you to create a Root CA certificate and issue a SSL certificate using Root CA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.