2

I'm running version 0.10.8 of Visual Studio Code in Xubuntu 14.04 x64, but used 0.8.4 before and didn't have this issue

When I try to push a commit to Bitbucket via VSCode, I get the following message:

Error: Authentication failed on the git remote.

Specifically, the Git Output log states:

Missing ipc hook
remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.
fatal: Authentication failed for 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'

Where XXXXXXXXXXXXXXX is my username@bitbucket/repository URL.

The same procedure in the previous version popped up a login screen where I entered my Bitbucket credentials and proceeded with the push. As a matter of fact, using the previous version in the exact same folder, still works as intended.

I already tried setting up a credential helper, but nothing changed.

My concern is if I'm doing anything wrong or it might be a bug. No bugs seem to be filed for this, but I might be wrong.

Should that not be the case, can anyone share some pointers on how to fix this?

  • Joum, did you ever figure this out? I am on Visual Studio Code 0.10.8 on Debian Jessie and I get the same error when I try to push to Gitlab. – Animesh Feb 20 '16 at 23:48
  • nope, nothing yet... got back to using 0.8 for the time being... :S – Joum Feb 21 '16 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.