5

MTP suddenly stopped working on my desktop running Windows 10 Pro N and I can't transfer files between my android devices through USB. I already installed the Media Feature Pack for windows before, I reinstalled it but it didn't solve the problem.

In windows explorer there is just a grayed out USB-Drive and I can't do anything with it.

In the device manager the MTP device is in the 'Other devices' category with a yellow exclamation mark. I tried deleting the driver and updating the driver by selecting 'MTP device' from the driver list but it didn't help.

I tried it with a Oneplus One and a Nexus 7 (2012) and neither of them worked. I also tried it with a different USB cable. Adb works fine and MTP works on my laptop, which also runs Windows 10 Pro N with the Media Feature Pack update.

Any help would be appreciated.

  • uninstall any android device drivers from device manager, connect the phone again and let WIndows install the drivers again. Look if this helps – magicandre1981 Feb 11 '16 at 5:32
  • @magicandre1981 done that, didn't help – Longi Feb 11 '16 at 11:39
  • What is the error code in Device Manager? – Moab Feb 11 '16 at 19:13
  • I would try uninstalling all the Root Hubs under USB, the scan for hardware changes to reinstall them. – Moab Feb 11 '16 at 19:14
6

I've faced similar problem, and finally this procedure worked for me:

Put your android device in MTP mode and uninstall the driver from device manager and follow these steps.

  1. Search for "wpdmtp.inf" file. (For example for Windows 10, 64bit OS, you will find the location in "C:\Windows\WinSxS\amd64_wpdmtp.inf_...........")
  2. Right click the "wpdmtp.inf" file and select install. Wait until the driver automatically gets installed.

Let the PC be connected to internet while doing the above process.

Start using the your Android MTP. Enjoy!!

If problem still exists keep exploring about the error messages until you find the solution.

Never give-up :)

  • Unfortunately I can't try this out, because i reinstalled windows long after I posted this question. Thanks for the answer anyway! – Longi Sep 7 '16 at 13:26
  • Few notes about Srikanth's answer - 1. The name of the driver may be "usb composite device" (you can find the correct driver by looking for the driver that appear only when you connect your MTP device) 2. Restart your pc after uninstalling the driver if you ask for it (IMPORTANT) 3. You can find "wpdmtp.inf" in C:\Windows\INF (Windows 7,8,10 64bit and 32bit). The problem is a Windows update called "Microsoft - Other Hardware - MTP device", you can use this tool - download.microsoft.com/download/F/2/2/… to hide this driver. Thank Srik – Avishay116 Sep 12 '16 at 19:54
0

I don't know when this problem started for me, maybe after installing root? MTP option from phone just disappeared, I could only charge it form PC. No fixes I found online helped me. Reinstalling drivers did nothing. Enabling debugging same. Unistalling root didn't help too.

The only thing that fixed this problem for me was UPDATING my ROM. I updated from MIUI 8.5 by xiaomi.eu to MIUI 9.5 by xiaomi.eu. Wiped only cache and dalvik. I didn't lose any files and everything worked after update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.