I am having problems getting the search indexing in Windows 10 to work. This have been bugging me for months, and I have searched the Internet for hours without finding an effective solution.


When I click on the start button and start typing (a file I know exists) it does not show up in the search results, even if I have included the file in the search index.

The search will find applications in the start menu such as calculator, word, etc..., but not files from directories I have created.

What I have tried to solve the problem:

  • I have double checked that I have added the directories I want to include in the "Indexing options".
  • I have checked that "Windows search" is set to automatic in services.msc.
  • I have tried to restart the "Windows search" service.
  • I have tried to rebuild the index in search options.
  • I have checked that SYSTEM is listed under "Group or user names" in the security properties of the folder I want to index.
  • I have tried to delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}\TopViews\{00000000-0000-0000-0000-000000000000}.
  • I have tried to run the following command in PowerShell, but this gives me en error message, Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
  • I have tried to "Reset Windows" with the delete everything option.
  • I have tried to create a new administrator user.
  • I experienced a similar issue in Windows 10 search does not find documents by default - can you try pressing the document icon or More / Documents, perhaps this will show the files to you?
    – Suma
    Sep 28, 2016 at 9:22
  • I am having similar problem. I found that while rebuilding the index I would get results, but not when it's complete. I would also get results a few seconds after restarting the Search service, but then it'd stop displaying file results again. I also tried similar steps as above.
    – thomthom
    Aug 22, 2020 at 10:45

3 Answers 3


Your question/problem sounds very interesting since you tried already a lot or in my opinion nearly everything possible.

Some ideas that might help:

Idea 1: Broken folder right inheritance

Did you check that the path down to the folder has system rights? I saw that you checked for the current folder, but all folders above need that as well. The easiest way to do so is checking if the system right for the folder is inherited from root folders.

Steps to check the inheritance:

Step 1:

Right click on the folder -> Properties.

Basic folder rights

Click on Advanced.

Advanced folder rights

Now make sure that the root folder (inherited from) also has system rights.

Idea 2: Ambiguous path/too long path

Check your path it might be either too long or has symbols that "crashes" the path. To make sure, move your folder to a different place and rename. I already had similar issues with Windows.

Idea 3: New User Profile

If all that didn't help, you might want to consider a new user profile. To check if this helps, just add an additional user to your PC, login as the new user and add your folder to the index. Now give Windows some time to index and check back later if it worked.*

Idea 4: Windows Reset

It's the last resort. If you are running Windows 10 you might want to consider resetting Windows. (Settings -> Recovery)*

* Please remember when doing the reset to not install any program and just test the indexing since defective programs could influence the indexing.

  • I'm sorry I overread that, you are right. Then the only plausible answer is the folder path, I would strongly recommend checking the length and symbols inside the path. In addition its necessary to mention that after the reset nothing should be setup and only the indexing should be tested, since a reset and then installing everything can end up with the same problem. (If for example an defective application is crashing the indexing). Thank you for your suggestion I corrected my answer above.
    – Markus
    May 11, 2016 at 13:13
  • 1
    Thanks Markus. New user profile didn't work. Windows reset I have tried already. The first thing I did after reset was to check if the indexing worked. It did not. I have given SYSTEM "full control" of all the folders in the whole folder path. I have checked the length of every path with "Path Length Checker.exe". The longest file paths are 250 characters. So I tried indexing only folders with shorter file path, but this did not work either. I am speechless...
    – Arete
    May 11, 2016 at 15:38
  • Another idea: Check the eventlog. (Start -> run-> "eventvwr") For diagnostic reasons you may want to clear the Application and System log beforehand, then restart the PC and work through the eventlogs / errors appearing.
    – Markus
    May 11, 2016 at 19:17

I was not getting search results for .docx files. When I looked at indexing options then Advanced, and then file types, I found that file types of .docx were set to properties only so I changed it to properties and contents and it then worked.


I also have this issue on my new Windows 10 computer and found it so annoying - my last computer worked perfectly!

Today I did found a solution that works for me - I will share it here.

For example - I'm looking for a file named 17171-EAM (which lives in a folder 17170-17171-17174-Earrings) When I search for 17171-EAM, nothing comes up, but when I search for 17171-E - the folder listed above, comes up, and I am at least able to get that far. All I have to do now is open the folder and find the file inside.

This is not a complete solution but at least it's something.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .