2

Here is my scenario:

I have two computers, one a windows 8.1 machine that hosts the HP LaserJet 4100 printer. It has a LPT port, which is used by the printer. I have printed pages on the printer successfully from that machine. The other machine is a windows 10 machine. I have been trying to share the printer on the network via the windows 8.1 machine and add it to the windows 10 machine. I have followed several online tutorials that give me instructions on how to do this. Both computers are connected to the building wired network.

I have followed this link

And this link

And multiple others as well.

After setting up the printer on the network, I go to the Windows 10 machine and click "Add new printer". As seen from the links above, I have enabled printer and file sharing and disabled usernames and passwords. Both machines are in the default workgroup "WORKGROUP". I have attempted to add the printer by typing in the IP address when selecting the option to add the printer via the IP and I have also tried adding the printer by typing in "\{computername}{printername}, however when I do this for the first time, the windows 10 machine asks for a username and password. The Windows 8.1 machine has no password, just a username. This is odd, because I have disabled the ability to use usernames and passwords when adding this printer. I have put in the {domainname}{username} and a blank password, since there is no password on the machine, and I have received an error that says "Access Denied". I have looked into the permissions given to the printer when looking at the printer preferences and when All Users or Everyone is selected, the permissions to print documents and manage the queue have been given to all users.

I have tried to add the printer when it was configured to manage the queue on the client machine and when it was configured to manage the queue on the host computer. Neither configuration has worked.

I´ve continued to try this same process over and over again, even on another machine on the network, and yet I am still unable to add the printer. Help is greatly appreciated!

  • (The close votes thus far are for migrating to SuperUser. In my case, it was mainly because I think the question will get more love there.) – Katherine Villyard Feb 9 '16 at 23:40
  • You have not mentioned if the computers can actually communicate with each other. Are you able to share files between them, browse folders, etc. regardless of the printer issue? – CharlieRB Aug 10 '16 at 20:17
0

IIRC you must set a password on a windows account in order to share files or printers. Mainly its how Microsofts sharing works as it expects a password even though you don't have one, and leaving it blank doesn't work either. In my experience setting a password on an account that is admin works more often then not setting one. So you can try setting a password and see if it allows it then. When you do set a password you can have your machine remember the credentials and it shouldn't bug you about it later on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy