1

Model: Acer Aspire S7-391; 256GB SSD/4GB RAM; OS: Windows 10

Before going dead, the laptop used to randomly display 'no bootable device found' warning while turning it on. But usually it booted up with two or three times using the power button. One fine day, it went off suddenly while using it on battery and since then whenever i try to power it up - there's only black screen without Acer logo. Now, the present state is whenever I power up the laptop, there is no response except the continuously glowing power LED till i manually power it off.

I tried the following solutions after reading some forums..
Connected with an external monitor to rule out the screen issues
Battery reset (pinhole)
Removed and reinstalled battery
Removed the SSD and tried to boot - still black screen. So reinstalled it
Tried hardware reset using power button and F12 key (In S7, F12 is Fn+F12)

Assuming it to be a corrupt BIOS after reading a number of forums where there are numerous reports of Acer Aspire models suffering from similar issues, i decided to do a BIOS recovery. I downloaded the "BIOS_Acer_2.18_A_A.zip" from their website and extracted the files on to the root of a "FAT32" formatted USB stick. Removed the battery out of the laptop, and plugged in the power cord. With the Fn+Esc keys held, i used the power button to turn the laptop on and then released the keys after the Power LED turned on. But there is no response (no symptoms of USB stick being read - the green LED indicator which blinks when it is read did not even blink once). I tried to rename the "isflash.fd" file to "Heliumx64.fd" as mentioned in their service manual, no luck. Now my question is - Was i supposed to change the BIOS settings (while the laptop was working) in order to do a BIOS recovery through USB stick? What are the files that are supposed to be in USB stick? I am not sure if i am missing something here! Please help!

  • Have you considered that the root cause could be a dying hardware component, e.g. a bridge chip which first lost device connectivity and later suffered from a more secere problem? – Run CMD Feb 11 '16 at 15:29
  • @ClassStacker I first thought maybe my SSD failed. In case of a hardware failure, i have no options left other than replacing the motherboard. I wanted to try everything possible before ditching the board. – Comfortably-numb Feb 12 '16 at 3:54
  • Today i went ahead and removed the RTC/CMOS battery for a while and plugged it back in. I reinstalled the battery pack and the moment the AC power was plugged in the power LED turned on without opening the lid / pushing the power button. (Just posting whatever my laptop does atm) – Comfortably-numb Feb 12 '16 at 15:01
  • UPDATE: Turns out that a capacitor was blown. I replaced it and now it is back to normal! – Comfortably-numb Mar 11 '16 at 7:27
0

It turns out that Acer's 'black screen of death' happens even when there's a minor issue such as a blown capacitor on the main-board. First thing I did when the black screen was to try and recover the BIOS as suggested by many people, however i was never able to make the ultrabook to read the USB drive. In this situation, i took it to a friend who has some knowledge on motherboard electronics and bingo - armed with a multi-meter he found out that there was a blown capacitor. He used a heat gun to remove the bad capacitor and replaced it with a good one. The moment i opened the ultrabook it started working like it did not have any problem. There it is now - it was not a BIOS issue but a blown capacitor in my case!

  • I'm glad you found the root cause of the problem. I was suspecting that it was a HW problem. Please be aware that there's not much of a chance to find something minor on a mainboard these days. Almost anything on a mainboard can lead to a malfunction. And it may or may not be related to the boot self test or required at boot. – Run CMD Mar 14 '16 at 7:42
  • @ClassStacker Yeah i was bit lucky in this case because the blow out was located the moment he started testing the board. It could have been more worse with me trying to fix the BIOS.. – Comfortably-numb Mar 14 '16 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.