I'm trying to convert Jupyter notebook to .pdf on Mac.

However, it tells me

nbconvert tailed: pdflatex not found on PATH

So, I went looking around and someone said, "Install mactex because this other way takes days to compile". So I did brew install Caskroom/cask/mactex and it finished without telling me there was a problem, but unfortunately it didn't install pdflatex that I can gather. And 'mac install pdflatex' doesn't bring anything useful up on Google for me maybe my bubble sucks.

How do I install pdflatex on my mac?


Yes, same story with my MacOS Sierra:

(1) installed mactex with homebrew cask, but no pdflatex found after that:

$ brew cask install mactex

$ which pdflatex

[no location]

(2) relaunched the terminal app

(3) pdflatex found:

$ which pdflatex


| improve this answer | |
  • For me just cmd+t in iTerm helped. – mrgloom Oct 31 '19 at 11:34

Install BasicTeX

To get pdflatex for Pandoc on macOS, install BasicTeX. Many people recommend MacTeX, which is a much bigger package than you need. BasicTex is produced by the same people who make MacTeX, but without, e.g., the GUI applications that make it so slow to download and install.

  1. $ brew cask install basictex
  2. Restart Terminal.
  3. Convert LaTeX to PDF.


Say you want to convert LaTex to PDF with Pandoc. You'd write:

  1. $ pandoc sourcefile.tex -o output.pdf, which fails with error pdflatex not found. Please select a different --pdf-engine or install pdflatex.
  2. So you install BasicTex, $ brew cask install basictex.
  3. Then restart your Terminal, and
  4. Run $ pandoc sourcefile.tex -o output.pdf again. Success!
| improve this answer | |
  • Installing basictex this way did not seem to work for me for generating a PDF: $ pandoc a.tex -o b.pdf [WARNING] Unusual conversion: to convert a .tex file to PDF, you get better results by using pdflatex (or lualatex or xelatex) directly, try `pdflatex a.tex` instead of `pandoc a.tex -o b.pdf`. pdflatex not found. Please select a different --pdf-engine or install pdflatex – Taylor Edmiston Jan 15 at 2:18
  • I get the same error as Taylor Edmiston. Additionally, pdflatex itself errors a lot of could not find *.sty and then doesn't generate a PDF at the end... – theonlygusti Feb 3 at 2:09

It appears that brew does not, technically speaking, install mactex. It just downloads it.

I had to use the quick launch and type in mactex which popped up an installer.

After it finished I pdflatex existed, though I did have to start up a new shell - I'm assuming it did something to my path.

| improve this answer | |
  • 3
    I just tried and installing the cask did install MacTeX. But I had to start a new shell instance for pdflatex to be recognisable. This is because installing MacTeX modifies your PATH by including /Library/TeX/texbin which is where the pdflatex binary lives. – Dennis Feb 2 '17 at 18:42
  • I ran brew cask install mactex but pdflatex didn't show up in /Library/TeX/texbin. Instead it was in /Library/Tex/Distributions/.DefaultTeX/Contents/Programs/x86_64/pdflatex. – ijt Jan 18 '19 at 5:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.