1

I purchased this mini-pc, Kaser YF751A-W. The hardware is closed, and I see no screws, so I can't go unplugging drives, or changing any switches/jumpers. The manufacturer's website kasercorp.com (listed on the box) doesn't have the product listed. The only additional information I can find is this pdf doc from a walmart site that happily says it supports Linux!

I'm trying to use a USB stick to install Linux. I've tried multiple distributions, x86 and x64*. I've verified the USB stick boots on another system, and I've created the bootable disk using unetbootin and rufus. All of these produce the same result, so I don't think my method or materials are the problem.

I can get to the BIOS, and I've tried the basic things, like setting only the USB stick in boot priority (this results in booting straight to windows), and using the boot override menu to select the USB stick directly (this makes the screen flash, then return to the override menu.

Googling around quite a bit, I've found people recommending things like making sure secure boot and fastboot are disabled, they are. I've tried many, many options in the BIOS, as there are some interesting ones, but nothing seems to get the system to boot to the stick. The other thing these sites recommend is going to the 'advanced boot options' in windows and trying to edit the UEFI options from there (this boots me back to the BIOS) or trying to select the USB device to boot to from there (this boots straight back into windows).

I'm thinking the problem is under the Advanced -> OS/BOM Configuration section of the bios where there are some unconfigurable settings that say: BOM Selection Switch Force Windows/BOM3.1 Pre-OS/BOM Selection Windows 8.X/BOM3.1 OS/BOM Selection Windows 8.X/BOM3.1

Anyone know how these options might be changed?

The only other thing I can boot to other than the preinstalled windows is the EFI shell, but I'm not sure what to do from here to fix the issue.

I've "opened a ticket" and sent an email to the manufacturer, but I have low hopes for a response.

*It's a 64bit processor, but the preinstalled windows is 32bit, and the efi shell is 32bit. **I've fired up EasyUEFI and VisualBCD but it looks like the BIOS, where I have only the USB enabled. I've considered deleting the windows entries, to see if the system freaks out and lets me boot something else, but I consider that the nuclear option, as it might brick the device.

  • Try spamming f2, f8, f10 and f12 immediately as the computer powers on. If one of those keys is your bios key, skip trying it and try the others. Most likely f8 is going to work. What you're after is a (hopefully present) boot device selection menu that is available the moment before the configured bios boot options are going to be used. From there you should be able to select the USB key, provided that you've formatted it correctly. – user72945 Feb 12 '16 at 4:08
  • Also can you provide more details about how you created the USB key with rufus? Take a screenshot of Rufus, this will show your exact configuration used. There's more than one way to make a USB key with Rufus. – user72945 Feb 12 '16 at 4:10
  • How about USB hard drive with Linux image? Or USB external dvd? Bootable USB has more moving parts so to speak. – wbg Feb 12 '16 at 6:00
  • Thanks for your replies! @TechnikEmpire I've just now attempted to reset the system a couple times spamming f2, f8, f10, and f12. I tried this earlier with f9-f12, but at your suggestion tried these four. The system continues to boot into windows normally. I've uploaded a screenshot of my rufus config. – Phluffy Feb 13 '16 at 5:44
  • @wbg the hardware has a microsd slot. I'm trying to install a live CD onto a microSD now to see if it'll boot off that... *Update: The BIOS doesn't see the microSD slot, I can't choose it as a boot option naively (without using a USB adapter; using the adapter doesn't help). – Phluffy Feb 13 '16 at 6:22
1

The fact that the firmware is 32-bit creates complications. To install Linux in EFI mode, you'll need a 32-bit boot loader, and possibly a 32-bit distribution; however, few or no distributions provide 32-bit EFI boot loaders on their 64-bit installation images, and vanishingly few provide EFI boot loaders on their 32-bit versions. (Debian is the only exception that springs to mind, and I've never tested it; but the claim is that its 32-bit version ships with a 32-bit EFI boot loader.) To install most distributions in EFI mode, you'll need to jump through hoops to add a 32-bit EFI boot loader. This will be easier with a 32-bit distribution than with a 64-bit distribution. You can find tutorials on how to do this for certain combinations on the Web, mostly aimed at tablets and netbooks. Here, for instance, is some guidance on installing Ubuntu in this way.

The other option is to install in BIOS/CSM/legacy mode; however, this approach requires that the firmware provide a Compatibility Support Module (CSM; aka "legacy boot support" or some similar term). Most 64-bit EFIs ship with a CSM, but I get the impression that this feature is rare among 32-bit EFIs. (The only 32-bit EFIs I've heard of with this feature are old Intel-based Macs.) Also, with a 32-bit Windows installed in EFI mode, managing a dual-boot with a BIOS-mode Linux will be tricky to manage -- you'll need to either rely on the (usually very awkward) built-in boot manager or install my rEFInd boot manager and edit the scanfor line in refind.conf to enable the hdbios option. (OTOH, if you install a 32-bit distribution in EFI mode, rEFInd will probably enable booting the kernel directly in EFI mode, which can simplify things a bit.)

Overall, if you were considering the Kaser and some other computers, you might want to revisit that decision. Research the alternatives to see what type of EFIs they offer. It might be easier to return the Kaser and replace it with something with a 64-bit EFI than to jump through the hoops required to dual-boot the Kaser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.