Periodically, the internet simply stops working in my virtual machine, and the only way I can get it working again is to restart the host computer. Since I use the virtual machine specifically for testing web pages, this is, shall we say, a bother.

Details: I have Windows XP Pro running in VMware Player (v. 3.0.0 build-203739) on a Windows 7 host. It's set to NAT (shared IP address) because the firewall won't allow a bridged connection.

Every couple of days or so, first the internet slows down to a crawl, then eventually it stops working altogether. Both VMWare and the virtual OS report that they are connected, everything looks just peachy, I can reach the internet from the host, but on the VM, all web pages time out and/or report that the server could not be found. (Browser-independent; tried with IE, FF, Chrome, Safari, and Opera.)

When this happens, the only way I've found to restore the internet connectivity is to restart the host machine. Restarting the VM doesn't help, nor does refreshing network connections on either the host or the guest. (Although I'm not entirely sure I've found the proper way to refresh a network connection in Windows 7...)

I have not noticed any predictability about when the problem occurs, i.e. it's not immediately after I do anything special. It seems to occur mostly after putting the host to sleep once or twice, but it has happened even if the host has been in continuous use. It also seems independent of when I start using the VM - sometimes, I wake up the VM and the internet is really slow in it, then eventually stops working altogether; other times, I wake up the VM, use it perfectly happily for a while, then suddenly the internet is gone.

Does anyone know why this is occurring? Failing that, is there a workaround that's less drastic than restarting the host? (Windows 7 startup times are blazingly fast compared to previous versions of Windows, but it's still a hassle to close all my programs and reopen them again.)

Edit: while badges overall are nice, the Tumbleweed badge isn't helping me to solve my problem. Hasn't anyone encountered anything even remotely similar?

  • I've had similar problem but I use bridge option instead of the NAT. What I did, I made sure that both VMPlayer's NICs in the host - Win 7 - have their IPs assigned dynamically and have the guest with static IP. For example, if your router is then I would assign to the host and then to the guest provided those IPs don't conflict with your DHCP pool.
    – Darius
    Commented Oct 4, 2012 at 16:03
  • 1
    Just a note that I'm no longer experiencing this problem, because that particular computer gave up the ghost a while back. I'm now on a Windows 8 (hack, ptui) box and the internet seems to stay up just fine on all my virtual machines. If anyone else is having this issue and one of these answers was helpful, could you add a comment to that effect? I'd like to un-accept my placeholder answer and accept a real answer, but have no way of testing things.
    – Martha
    Commented May 3, 2013 at 16:10

9 Answers 9


This happens to me too. I did the following:

  1. I find the network adapter on the host which VMware Player is using (in Network Connections). In my case, it is named VMware Network Adapter VMnet8.

  2. Right-click on it then select Disable. I then wait for the Guest OS to report 'cable unplugged' from its taskbar (my guest is WinXP).

  3. Back in the host, right-click on the same adapter the select Enable. Wait for the guest taskbar no-connection icon to switch to the getting-an-ip-address animation, then after the IP address is allocated, test the connection.

My web access is restored with this method.


In my experience, if my host OS goes to sleep while the VM is running, I lose network connectivity from the guest OS, and the only way to resolve the situation is to reboot the host OS. However, I found that if I suspend the guest OS before the host goes to sleep, the problem never appears.


The resounding silence is impressive...

The workaround I've found is to set the connection mode to bridged, wait for it to realize it can't connect that way, then set the connection mode back to NAT. Not terribly satisfying, but better than restarting the entire computer.

  • 1
    If you think it might help, you might consider adding a bounty to your question.
    – heavyd
    Commented Mar 15, 2010 at 15:30
  • Have you tried ipconfig/release and ipconfig/renew ? Or even that times out on you?
    – Darius
    Commented Oct 4, 2012 at 16:05

I tried a few of these solutions. Here is what worked for me with a Linux guest on a windows host:

  1. Open virtual machine settings
  2. Select the Network Adapter and click Remove
  3. Then Add... > Network Adapter > Finish > OK
  4. Then suspend the machine and resume it and it works again!

Better than restarting the host.

  • This one worked, when accepted answer didnt. Also, currently no needs for 4., since VMWare did it automagically after 3.
    – Sanctus
    Commented Sep 28, 2020 at 12:46

I have the same problem, very annoying. Finally I found the solution is:

Player -> Manage -> Virtual Machine Settings ... -> Network Adapter (Bridged Automatic) -> Network connection -> Configure Adapters -> Select the host network adapter(s) you want to antomatically bridge:

Choose the one you have the physical network card and uncheck the VirtualBox Host-Only Ethernet Adapter.

Hope this will help.

  • 1
    In my case I was using a bridged connection on Win7. Whenever I changed the USB dongle on my router, or unplugged my LAN cord, I lost all connectivity to my virtual machines on Workstation 10. I followed this answer and removed all adapters except one. Rebooted the virtual machines and they worked! Thanks :)
    – TryHarder
    Commented Jul 22, 2014 at 11:28
  • 1
    Slight modification. Go to VMware Workstation -> Edit -> Virtual Network Editor-> Network Adapter (Bridged Automatic) ->Click Automatic Settings then remove the network adaptors you don't need.
    – TryHarder
    Commented Jul 22, 2014 at 11:55

On vmware player right clic> disconnect the network using the icon at the bottom of the window.

Go in the windows network connections, disable all connections except the one you want VMware player to use. Reconnect vmware player. Now it should work.

  • Go to Virtual Machine Settings.
  • Click on Network Adapter.
  • Click Remove.
  • Click Add new network adapter.

Should solve the problem.


I have the same network connectivity problem upon first startup of the vmimage (i.e. the network appearing OK on both host and vmware image). I close down the vmware image, close down vmware, restart the router, restart vmware, restart the image, and it's back on the network.


I too had the same problem with VMware Workstation 12 on windows 7. After lot of trial and experiment, the following solution worked for me. This fixed the problem permanently.

  1. On VMware host, Goto network and sharing center->Change Adapter Settings
  2. Right click on VMware network adapter configured for NAT and disable it.

Thats it!. It works.

It sounds funny isnt it ? Here is the explanation Even though the network adapter is disabled, the VM ware NAT service and VM ware DHCP service will continue to serve the request coming from guest OS. This is because, the network traffic between guest and host is mere memory copy with in the VMware process.

But it has a side effect. The host machine will not be able to reach the guest on the IP configured on NAT interface. To overcome this, I created a second VMware virtual network adopter(In VMware workstation, Edit->Virtual Network Editor) with host only option and present a second network interface to the guest OS. Now, the host can reach guest on this interface.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .